NAS drive settings on OSX share [Solved - Permissions Issue]

Hello - new user here, loving Roon to bits and so far it has been a complete revelation, so I am determined to get over this small problem.

I have an OSX based system with a dedicated headless Mac Mini as the core. It has an ethernet connection to a ReadyNAS drive where the music is stored.

The problem is the Roon software cannot DELETE from the drive.

When I try to delete an album or track I get “Permission Denied” error, the file itself if not deleted yet the file data is deleted as if you right click on the file to see “View File Info” it the UI states the “Track is not in your Library”. In the “Library Maintainance” section there is nothing to “Clean Up”.

The connection between the headless Mac and the NAS drive is set up as an automount, so the music is seen as /mnt/music following the following instructions:

  • In /etc/auto_master add /mnt auto_mnt
  • Then create auto_mnt and add music
  • sudo automount -vc

Checking the /mnt/music folder in OSX everything looks fine and I have read and write as the logged in user. Roon is seeing the drive as a local drive.

Is there simple permission fix I am not seeing somewhere?

Obviously, I have noticed the Network Drive storage option which I could use, but I worry now that if I added it as a source I would duplicate everything and I have done a lot of Album merging so would prefer very much not to start from the beginning again.

Any advice most welcome and appreciated.

If you try to delete a file yourself (either from Terminal or Finder), does it work or does it also encounter the permission error?

Yes it deletes fine. Also when deleted by roon the file is actually deleted. It’s just the error message then the database record remaining.

If you have deleted a file and the database still shows, try going into settings/library and running clean up.

Hello @Barrie_Hadfield,

We have previously seen some strange behavior with auto-mounting via the OS instead of directly from within Roon. Can you please let me know what your experience is like if you try to edit the storage location and point it directly to the share? Ex. smb:// as the Network Share Location and also adding the same credentials you use to log in to it. Does deleting work as expected then?


Hello - I solved it!

This was just some strange NAS permissioning thing where it seems that even though the roon user had access to the share, there were folders in the share with different permissions (different owners).

I solved this through the NAS interface by resetting the owner of all the files and folders in the share.

Thanks for the help with this. :slight_smile: I am a happy user again.

1 Like

Happy to help and glad to hear you got the permissions issue sorted out @Barrie_Hadfield, hope you have a great day!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.