NAS Library Scanning (automatic addition and removal), MP3 Reproduction Problems

Hi, I’ve been using Roon 1.3 for about 1 month as a new customer and I have experienced several issues.

My initial configuration :

Roon 1.3 (build 223) (the last one available at the moment)
Roon Core running on an iMac Retina 27’ 5K 4 Ghz Intel i7 2016 with 32G DDR3 RAM, macOS Sierra 10.12.4
Roon Client : Auralic Mini Firmware 5.0 beta 4 (to be fair Roonready is still in beta and not certified yet)
DAC : Emotiva XMC-1(the Auralic Mini connected to the XMC-1 via USB)
NAS : QNAP 453 Pro, Inter Celeron based, 8 G Ram used only a as network drive
All the networking is based on ethernet cables with the devices connected by cable through a gateway (no wifi)
Audio Collection: 85K tracks, about 6000 albums

The 1st main problem I experienced was linked to the continuous scanning and automatic progressive loss/erasing of albums from the Roon library located on the NAS …
When I say “loss” I mean that after building the full library and having completed the background analysis so with a system apparently “perfect” I have seen that after adding additional albums to the library, after a while but happening regularly I was able to see “live” the counter of the library albums progressively decreasing like if someone would have removed progressively the albums from the library. This countdown was usually stopping at different levels … (for example if the full library was always about 5800 albums when the "mass removal action’ was initiated, once I have seen the mass removal of the albums stopping at a level of about 1000 albums, another time it stopped at about 200 etc…
I found a thread which was describing a similar problem and how this could be linked to the unreliability of OS X in confirming the content of the watched folders…
After the album removal the system gets in a loop where the scanning keeps adding again albums to the library, then something happens and start to remove them again making the system almost useless as it is a constant library scanning…

Disappearing Tracks
We’ve investigated this about half a dozen times over the past year. It’s actually more of a problem with OS X than with Roon (which is why Roon on other platforms does not suffer this symptom), and it is relatively rare, meaning we have many users using network storage on Mac without this symptom, and only a handful who see it. This suggests that it’s in some way correlated with setup details or habits of those users.

Anyway, this was pretty annoying as it made Roon totally useless in my network configuration and I was forced to move all the audio library from the QNAP NAS to a RAID 5 4 disks hard drive directly connected to the Mac which is seen as a local drive.
The library problem is now completely solved in the new configuration but using the system more extensively I see sometimes strange behaviors from Roon when I try to play some albums, sometimes using the DAC sometimes or sometimes even locally on the iMac using the local default zones: (System Output and Apple Core Audio).

I’d like to ask your support for this special case as it is not linked to the network, Roon is actually playing a local file on the iMac from the locally connected RAID drive and no networking is involved.

I have the same album:
’In a a Twist’ from Bria Skonberg

in 2 different versions: MP3 16 BIT 320 Kbps and FLAC 24Bit 96kHz.
The FLAC version which is obviously heavier is reproduced without problem from Roon on the iMac locally using the local system output while the MP3 is sistematically creating a repeating noise during the reproduction and practically blocks Roon until a new zone is selected.
I noticed that when this happen also the Apple Core Audio and System Output zone seems to disappear for a while, then they reappear. But every time the MP3 file is reproduced, it systematically generates the Roon problem.
The same album, located exactly in the same location where Roon has problem to play it, is reproduced perfectly from :

  • the OS X through the quick play activated pushing the space bar on the file from the finder
  • VLC
  • Audirvana
  • other players like the Aurora Blue Ray players etc.

This seems to prove that the album files shouldn’t be corrupted as they are reproduced perfectly with the other players…Roon is actually the only one having problem with this MP3 version…

Any possibility to check on your system ?, I could upload both versions for your check…

Thank you

Not a 100% true assumption. I had several FLAC files with corrupted headers that played fine in other players that would not in Roon. My solution was to resave/export the files to a new FLAC file so the headers were created correctly. You might be having the same issue.


Often if a file is corrupted roon would flag it in the settings under Settings|Library|Skipped files but I guess it’s possible it might try to play something that is not 100% and have some issue with it.

Personally had this where roon effectively wouldn’t start with a corrupt dsd512 file in the library after a new release…so @support might might be worth a tag. They will likely want more info and perhaps a copy of the MP3 file as they investigate.

Hi @Ubaldo_FRESIA ---- Thank you for the detailed report and sharing your observations with us. The insight is appreciated.

The behavior you’ve described in regard to the Bria Skonberg album (MP3) does sound like bad headers to me, but we can certainly take a look for you on our end :sunglasses: Can you send us over a copy of the content via a dropbox download link in a PM?

Furthermore, how was the MP3 version of the album created/obtained ?


Hi Eric,
thank you for your help, I’m not sure about the program who created the MP3 as I didn’t create the file.
I tried to verify the MP3 using some old Windows MP3 diagnostic program running under Windows in a Virtual Machine on my Mac but I had no clear results about problems… I will send you a PM with the Dropbox location of the files…

Thank you again for your help.


1 Like

Hi Daniel, thank you for the advice… as a curiosity which program did you use to identify the wrong headers ?

Actually, I think Mike checked the file out for me ( its been nearly 2 years ago). However, based on discussions before he completed his analysis, I had just gone ahead and transcoded FLAC to FLAC and it worked perfectly. Later, I ran into similar issues with several MP3s from various sources and did the same and it worked. I used dbPoweramp to redo the files, and, of course, I did not overwrite the original file, I saved it to a new location. In fact, I still have the original bad files saved somewhere.

Hi @Ubaldo_FRESIA ----- Thank you for your patience here.

I did have a chance to test with the provided media and can confirm that I saw the same behavior when not using “exclusive mode”, as soon as I turned on “exclusive mode” I had no issues with playback. To be clear this was only while using either “System Output” or “Built-In Output”, playing back to a USB connected DAC, even without “exclusive mode”, did not yield the same results. Furthermore, I did not experience any zones disappearing while the clicking noise was occurring, I did have to select a new zone to stop it, but nothing disappeared.

Moving forward, you mentioned the following:

“The FLAC version which is obviously heavier is reproduced without problem from Roon on the iMac locally using the local system output while the MP3 is sistematically creating a repeating noise during the reproduction and practically blocks Roon until a new zone is selected.”

Can you confirm if this issue is only reproducible when using the local system output or are you seeing the same when playing to the Auralic Mini + Emotiva XMC-1 zone? If you are seeing this only with the local system output this is what I would like you to try:

  1. Select “System Output”, play the album and confirm that the clicking is present, then pause playback.

  2. Select “Built-In Output”, play the album and confirm that the clicking is present, then pause playback.

  3. Leaving "Built-In Output"as the active zone, go into “device setup” and turn on “exclusive mode” in the “playback” tab.

  4. Once “exclusive mode” has been engaged, play the album again via “Built-in Output”, is there still clicking?

If the clicking sound HAS stopped…

  1. Now select the “System Output” zone again, restart the album, and confirm if there is still clicking.