NAS no longer available following software update

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus Serial #94C6911CFD7A
Operating System: Version 1.0 (build 175)
Roon Server Software: Version 1.6 (build 416)
Roon Labs Software: Version 1.0 (build 11)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Windows 10 Home; 64 bit
Verizon Fios Quantum Gateway
Netgear GS108 Gigabit Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Moon 390 Network Player

Description Of Issue

My system has been stable since February. Today I grooming music collection and received a message in Roon that a software update was available. I selected update. It appeared to complete.
Then Roon began having trouble connecting to core. I restarted PC, router, switch, Nucleus.
Under setting storage I had a message that “this drive is not available…”
I see no problems with my NAS and made no changes to it. I can see the network share in Windows Explorer and can see all of my music files.
I tried enabling and disabling drive.
In desperation, I deleted the folder in storage settings and tried to re-add the network share.
It tries for a minute or so then gives message “There was an unexpected error…”
I can see Nucleus if I enter its IP address in my Chrome browser. I seem to recall that I used to see Nucleus in Window Explorer under network but I no longer see it. Why? Also it appears to be using DHCP and I can’t recall if that is correct or whether it should have a static IP address?
Please help. Frustration level extremely high…

Hi @Robert_Crawford,

Thank you for reaching out to us here and apologies for the frustration. Can I please request some more information?

  • How have you been mounting your NAS to Roon, have you been using Hostname or the IP Address of the NAS?

  • Is there any change in behavior if you attempt to mount the NAS via IP Address if you have been using hostname?

  • Does rebooting the Network, Core and NAS (in that order) help with re-establishing communication with the NAS?

  • Can you share a screenshot of your Roon Settings -> Storage tab? You can use these instructions to upload screenshots to this community site.


Noris, I have to ask more questions before I can attempt to answer yours. This will show my lack of technical knowledge. Is a host name the same thing as the share name on the NAS? My NAS has a static IP and a share with my music files. It was addressed in the Roon storage setting as \NASF32D4C\public
I used the Roon select folder to select that share. How do I set it as an IP address? I’m using Nucleus just to run the Roon software. Should the Nucleus have a static IP address? I don’t believe it has. I used to see it with Windows Explorer. The Roon settings screen apparently knows the Nucleus IP address. I’ll get you screen shots when I get home. Thanks.

Hi @Robert_Crawford,

Thank you for the additional information here.

This indicates that you have been using hostname to set the share up. You can change from hostname to IP Addressing by going into Roon Settings -> Storage -> Pressing the 3-dot drop-down menu next to your current \NASF32D4C\public share -> Edit -> Browse… -> Add Network Share.

In the Add Network Share page, you can try inputting the static IP address of the NAS (e.g. \\192.168.X.YYY where X and Y are your specific IP values) and then also inputting the NAS credentials as you had them set up before.

Also, as a word of caution, static IP addresses should be handled with care. It is always suggested that an Address Reservation at the router level be performed instead of static IP. This is because if you were ever to switch your router in the future and the NAS or the Nucleus was still set to static IP, communication may not be possible.

E.g. If your current router is using 192.168.1.XXX IPs and you have a new router that uses 192.168.2.XXX IP ranges, the static IP would become invalid.

Please do send the screenshots when possible and let me know if connecting via IP address to the NAS helps.

Screen shots uploaded.

Changing the network share from \NASF32D4C\Public to \\public worked and it started to reload files. What happened that rendered the old syntax faulty?

Question - I have spent months grooming my collection to make sure commercially purchased music is identified in Roon. While a lot of the grooming involved editing music file tags, much of it involved the identify album feature in Roon, finding the appropriate match and aligning the tracks and discs. Is all that work out the window as Roon readds my music???

I also use a different share on my NAS for the Nucleus backups. I made the same type of change there.
Thanks for your support.
Robert Crawford

Hi @Robert_Crawford,

Thanks for the update here and glad to hear that switching to IP address has resolved the issue. We are looking into a few similar reports but I do not have any further info to share except that this is on our radar.

No, Roon should be able to match the metadata for tracks even if they are located in a different location. This holds true as long as Roon only “sees” one copy of the media files at the same time. The matching is done by comparing the files with existing Roon database entries and if the audio content of the files is the same it should be able to match the previously existing data. Can you please confirm that this is the case for you here as well?

A post was split to a new topic: Can’t access ROCK File System or NAS via Hostname

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.