NAS problem - path is already in use

I’m trying to add a watched folder on a Synology DS216SE attached to my network. The station itself is visible through finder, but when I add it to Roon I get a message stating that ‘the network path is already in use on your system.’ How do I fix this?

Hello @Jonas_Sjovaag,

Can you provide more info about your issue:

  • Version of the OS you are using ?
  • Network path your are using?
  • Maybe this folder was already mapped by finder when you was viewing it ?
  • Does this folder require authentication ?


Hi jonas,

I have the same problem with my Synology, did you resolve the issue?



Hi Paul
I resolved it by using the external IP for the Synology, so that’s why I didn’t reply to the thread. Still don’t know what the problem is though, but I’ve had the same issue with external HDDs connected to my Airport Extreme and resolved them in a similar way, ie by renaming the disk and things like that. My best guess is that there is a cache somewhere in Roon that does not update properly, but that’s just a guess.


Hi Jonas,

Many thanks for the “heads up.” I have a few issues and 14 days to resolve them.



Just installed Roon 7 days ago, and been experiencing 2 problems, but I thought it woul be best to resolve this problem first.

System is a Mac Mini - Os 0.10.5 - 2.5GHz i5 - 4GB Ram
Connected wire to an Ethernet switch
NAS is also connected wired to the same switch

After the initial set up I was able to connect to the NAS. After powering off the Mac Mini I have not been able to reconnect to the NAS. I receive the following message on the “Settings -> storage” page. “The network path is already in use on your system”.

Any help would be appreciated.

Thank you

What are the exact steps you’re taking to add the NAS?

Are you typing a hostname (like smb://DonsNas) or are you using an IP address? Or are you browsing to a mounted volume?

Let us know the specifics and we’ll figure out what’s going on here. Thanks!

Thank you Mike
I have tried both the static IP address of the NAS and the name. For example:


Is the NAS mounted in OSX?

Do either of those work if you go to Finder and enter them under GO > Connect To Server?

Yes the NAS is mounted by OSX at start up.
I was able to browse to the NAS in the “Storage” tab, and access & play files.
After shutting down the Mac Mini, and booting back up the NAS drive is not seen by Roon, and if I enter the smb://…into the path field I get the message.

Are you sure about “volume” in your smb-line? If you want to add your media share it would be


If you specifically want to point to the music folder it would be


If your synology share is indeed named “volume”, then your line is correct. But It looks a little bit suspicious to me.

Thank you for noticing the “Volume” in the smb path. That appears to have corrected the issues with the “path is already in use” message. Tracks are being imported now. Let’s see if the folder stays connected. My guess it will.
Thank you again.


Unfortunately, I get the same error message “The network path is already in use your system.” and already tried all the above mentioned path variations without any success. Each of the tried paths work in the Finder.

Of course, I don’t like to reinstall the software. Is there no other way to remove the “already used” path in the database or cache or settings files, whatever?

Thank you

The “The network path is already in use on your system” message is quite inaccurate and does not necessarily mean that the path is really in use.
On what device is your Roon Core running?

Could you provide a screenshot of your storage settings? This makes it sometimes easier to see a misconfiguration.

Hi Christopher,

The path should route to a Synology NAS with a share named “music”, the IP is fixed and a network internal DNS entry to “DiskStation”.

The Roon core is running on a Mac mini.

So i tried

Hi Christian,
The entry in your current settings looks wrong.
The smb-line never includes “volume”. I actually tried it on a different mac here and get the same error, when I add “volume” in the smb path input field. This error is always given if the path/share can’t be found (see last entry in the screenshot).

In favor of the Hostname I’d use the IP address to rule out nameserver issues. The last entry of your list looks actually quite right. If it really does not work, check the case-sensivity of the share name.
(“music” or “Music” or “MUSIC” or anything else?)

Check also the access privileges of the folder. Has the entered user access to it?

Hi Christopher,

Thank you very much getting back to me so quickly.

I tried again the last line: smb://
and also double-checked the case-sensitivity and user rights of the share which are both correct.

I tried around a little bit and might have found another source:
Please check the group your “roonserviceuser” is assigned to:

In my “test-scenario” the user “roonserviceuser” is in the group “users”.

Check the privileges of the group users:

In this case the group has no access to the folder “music”. I am getting the same error as you now. The group that is assigned to your user is not allowed to be blocked from the “music” folder. Please check if this is the case in your setup.

I tried the same as you did in your test scenario. Nothing changed.
Also tried to add the roonserviceuser to the administrators group with the same result.

But I’ve found my solution. I had switched on the advanced share permissions for the share “music”, but didn’t allow the user “roonserviceuser” to read in this share. Don’t know why I had switched on this. However switched on and allowing the user to read this share does help :wink:

Christopher, thank you so much for your support.

1 Like