NAS Server - Roon says path is invalid [fixed]

Im on a MAC and my NAS address is afp://GMUSIC._afpovertcp._tcp.local/music.

Any ideas whats wrong?

afp:// is not supported. Is your NAS reachable via smb?

As Bart already mentioned, you should use smb to connect to your NAS.
I’d also recommend using the IP address instead of the hostname. It should look like this:
smb://ip.of.your.nas/music

Enter the username and password in the corresponding fields and make sure this user has the required privileges to access the shared folder.

Also take a look at your NAS administration, if smb needs to be enabled first.

I have no idea, how would i find that out

Christopher’s instructions are likely to work. Perhaps you could share what NAS you are actually using?

its a Synology DS216

If the IP address of your Synology is unknown, you could download the Synology Assistant from Synology’s download section.

When you run it, it should see your DS216 and display the IP address in the 2nd column.

I’d recommend to try to use this IP address and use it in the path as shown in my previous post.
By default smb should be enabled as it is a very common network protocol.

If it does not work, you can also access the administration web-panel from the Synology Assistant by double-clicking on the device.

i tried typing in the IP address but that doesn’t work either, i can’t see anywhere in the Synology app to change the file path from afp to smb

It can be found in the web administration of your DS216 under Control Panel -> File Services.
It is called “Enable Windows file service” on Synology devices and needs to be enabled.

1 Like

great - thanks - all set now

2 Likes