NAS Share Problems with Roon?

I have a Melco N1A and an SGC i5 on which I’m running Roon. All of the devices on my network can see the Melco and connect to if except for the Roon server App running on the SGC i5. I’ve tried using the symbolic name of the Melco and it’s IP address with no luck. The same version of the Roon server running on my iMac can connect to the Melco, just not the instance running on the SGC i5. All known devices can see the i5, which I just got back from SGC with a new SSD and a new install of everything. I switch between the two instances of Roon in the Roon remote App. Any ideas about what could be wrong? Thx.

Hi @Robert_Schaub,

How is the SGC i5 connected to the network compared to the iMac? Are they both on Ethernet to the same switch or directly to the router? I would try connecting them in the same way and verify if the iMac is still functional. I would also double check to make sure that they are on the same subnet range, e.g. 192.168.1.XXX. Please let me know if that helps.


Yes, everything checks out per your note but I can still not get the i5 to recognize the Melco at all, and it did work before SGC replaces the SSD though that should really not be a problem.

Here are some more screen captures from when I use my iMac. I prefer using the SGC i5 for Roon server and this was not a problem before, really not sure what’s going on.

Everything is on the same subnet range (10.0.0.XYZ).

Hello @Robert_Schaub,

Thank you for posting those screenshots. Since this appears to be working from the iMac as expected and it’s just the Small Green Computer i5 experiencing the connection issues, I am wondering if this could be due to an SMB setting on the i5.

What is the model/manufacturer of your router/any switches in your setup?
Have you reached out to SMG yet regarding this issue? I am flagging @agillis here in case he can shed some more light on this issue.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.