NAS watched folder not available in Roon (Solved with IP)

Without starting a new thread my NAS has also been lost from the original link in Roon, the same trouble Paul was having. Yes, I can access the music files on my NAS from finder and other apps:

Hey @Celts88,

Since this behavior has occurred have you tried rebooting your Core machine and the NAS?


If what @dylan suggested does not do the trick. Try to use the IP of your NAS instead of the name… IE: \IP\RoonBackups and reports back :slight_smile:
Good luck!


You’ll find a number of similar threads on this very topic.

Despite a lot of investigation by @agillis, no solution was found in my case.

I ended up having to change ‘DS916’ to the NAS IP address e.g. Not ideal, but as the IP address is reserved on the router, there is no danger of it changing and messing things up.

I suggest trying this first, and if it doesn’t work, then you can at least discount it as one of the causes of the problem.

Good luck

1 Like

That usually implies a dns problem. In most home environment that use host names like this, Their dns comes from their router or the application is using mdns… (NAS OS in this case)

The mDNS name usually works better. Try DS916.local as the name. This is the mDNS name.

@Stampie this may also work for you.

1 Like

I usually stay away from anything application dependent and set everything static and than use the hostname. mdns has been poorly executed around this devices… I seen many NAS OS crash avahi and people just go nuts trying to figure out why it no longer works. Good luck OP! :slight_smile:

@Tech_Whisky_lab that mean you must be using your router as a DNS server to resolve names to IP addresses. This is also problematic as some routers can do this correctly and some can not.

The best solution. Use an IP address. It always works!!

I actually use hosts files (old school way) lol. But yea I can agree that IP will allways work.

I do that as well here but most non technical people don’t know how to do that. I try to post generic solutions that work for everybody.

I agree that’s why I don’t suggest it and suggested to use the IP to the OP. :slight_smile:

Got sorted

As suggested above I’ve used the actual IP of my DS916 and all working again. Thanks to all for your suggestions, much appreciated :+1:


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.