Need help diagnosing music dropouts

A couple of months ago I started getting music drop outs - and stuttering - during Roon playback. It was not associated with a particular piece of music. It was sporadic. But once it started, it would continue for several minutes. I spent WEEKS tying to debug it.

I ultimately concluded that the problem had to be my DAC. So recalling that over a year ago I replaced my DAC’s stock power supply that came with an SBooster PS upgrade. So I pulled that out and plugged the stock PS back in. All dropouts ceased! I was so thrilled that I had found the problem. But just to be sure - after a couple weeks of listening with no dropout - I plugged the SBooster back in, fully expecting the dropouts to return. But to my shock - now two weeks later - there are STILL not drop outs! Where did they go?

I’m posting now because I find myself scratching my head over this, and am hoping for some feedback, 'cuz this makes no sense to me at all.

I’ll elaborate on the problem, and the testing…

First, here’s my setup when the dropouts started happening.

When they first started I was listening to Tidal with Roon. And I should mention - it’s not on the diagram - but I did have a Jitterbug attached to the SOSE.

Thinking the problem might be with Tidal, I switched to a playlist of music on my NAS. No change. It took many hours of listening, but the dropouts returned.

So thinking it might be a Roon problem, I swapped the MicroSD card in the SOSE Cubox-i with one that had Volumio loaded on it. Volumio was set up to use the same music files on my NAS as Roon was. And without Roon in the picture anywhere, the dropouts returned. So it was not Roon.

Maybe the Jitterbug? I removed that, and dropouts continued.

So just for a change, I unplugged the SOSE Cubox-i with Volumio, and plugged in my Aries Mini. I started playing music from Tidal on the Mini, again resulting in dropouts.

Now I’m suspecting network problems. So - as a test - I started a huge batch job that copies all the music files on my NAS, and that caused dropouts to start. And once they started, they did not end - even after the batch job was finished, until I power cycled my DAC. Then everything was fine. This was quite repeatable.

I repeated this test - running a batch job ripping tons of files off my NAS - using the Aries Mini playing Tidal music. Same results. So now I think I’ve found a network problem. On the back of that I did some network configuration, primarily increasing my WiFi throughput. So - thinking the network was not fine - it was time to test Roon again.

So I started the RoonServer on my NUC back up, and plugged the SOSE (configured AS a SOSE) into the network and my DAC. And with Roon playing songs on my NAS, the dropouts continued.

So I copied the offending music from my NAS to the RoonServer NUC. And playing that locally stored music, the dropouts continued. Maybe there’s still a problem the network - the music going from RoonServer to the SOSE?

So I pull the SOSE out of the loop, and ran a long USB cable from my RoonServer NUC directly to my DAC. And the dropouts continued. This made it clear it was not the network - RoonServer playing locally stored music to my directly connecting NAS proved it.

This series of tests caused me to conclude it was not Roon (problems continued without Roon), it was not the Jitterbug (problems continued without it), it was not the network (problems continued when the network was not involved), it was not my NAS (problems playing locally stored music). So what’s left? My DAC.

So I fired the Aries Mini up again. But this time, rather than outputting music to my DAC, I let the Mini use it’s own DAC, playing music from my NAS. And guess what? No dropouts. Listened for days. None. Nada. Zip.

It had to be my DAC.

So, as mentioned in the OP, I first wanted to ensure it was not a power supply problem with my DAC. So I hooked everything back up the way this whole thing started (see the diagram), but replaced the upgraded power supply on my DAC with the stock PS. No dropouts! For days! Eureka! I found it!!!

But just to be sure, I put the upgraded PS back, and waited for the dropouts. But they never came back. :confused: Huh?

This is nothing less than bizarre, and would LOVE anyone’s ideas as to what is (or was) going on.


1 Like

You’re not alone, I’ve had the same for a while now and I’m certain it’s not DAC related - it happens with any of 4 dacs. I’ve proven it’s not network related and am now looking into CPU behavior relative to playback and interacting with Roon via tablet. What I can see thus far is that using the UI can/does cause momentary CPU utilization spikes from nothing to around 25% - this on an i5 with 16GB ram.

Thanks Evan. I’m aware of your problems (you know why, nod nod, wink wink), and find it fascinating. But I think we are in different places.

In my case - keep in mind - I had these dropouts when Roon was nowhere in the picture. That was with the RoonServer shut down, and playing music with both the Aries Mini, and with Volumio. The ONLY common thing I’ve had is the DAC. AND the problem went away when I used the Aries Mini’s DAC.

So it really looks like the DAC, except of course, the problem is now gone. What the heck is going on?

There are two possible problems that I’m aware of.

First is the possibility of there being more than one problem causing the same symptom. So as I move various pieces of the puzzle around, I take one problem out of the test, but leave the system exposed to a different problem. Say for instance there was a Roon problem AND a network problem.

However, I suspect that is not the case, as this problem came on rather abruptly. And it seems unlikely that multiple problems would manifest themselves at the same time.

Another possibility is something I did not mention previously as I did not want to confuse the issue…

The SBooster’s power supply has a little connection adapter on the end of it, allowing it to be used on many different devices.

When I unplugged it from the DAC, that little adapter came off. As if it had been loose. So that opens the possibility that the DAC was getting less than optimal power, manifesting in dropouts.

I’m not an electrical engineer, but I would assume (yes - I’m assuming) that if the DAC did hot have sufficient power, that it would not work at all. And if it was a bad power connection, why would power cycling the DAC cause the dropouts to stop, as was often the case in my testing?

I would think this would be a great question for the DAC maker actually. In terms of computers, I have over the years seen both unstable and lower than spec voltage cause a wide range of different symptoms. I don’t find it out of the realm of possibility for problems in supplied power to cause the DAC’s USB connection to become erratic, as I have experienced USB ports that have become “flakey” until a system reboot that was due to a failing power supply.

Daniel - I find that to be quite telling. I’d be surprised if a loose power connection could not present very much like a failing power supply. So maybe that was it.

If so, then WOW, what a pain-in-the-a**, to have spent weeks (seriously weeks, and weeks, and weeks) diagnosing a problem only to be a loose power connection.

If that’s true, there’s a joke in there somewhere, and my audio hookup and diagnostic skills are likely the punchline. :wink:


Well, excellent job and and a testament to your perseverance! Now time for a beer. :slight_smile::beers:

If there ever was such a time, it is indeed now. :wink: Thanks.

Kind of off topic (but hey, it is my thread), but I thought I was going to have to buy a new DAC. Now I’m kind of disappointed that I don’t.

With a broken DAC, I could have called it a necessity. Now it would be an expensive upgrade. Bummer. That said…

I’ve been doing a ton of DAC research because of this. And If I did have to buy a new DAC, AND because MQA is going to allow Roon to do software decoding, I’d be buying buying a PS Audio Direct Stream Junior in a heartbeat. With their old equipment turn-in offer, the price drops to the point that I’ve convinced myself that they are one of the best deals in audio.

And now I’ve lost my excuse for why I have to have one. :disappointed:

Let me just state that I will gladly fly over and break your DAC for you. We could share a beer afterwards.

Only problem: you won’t be able to use it as turn-in any longer, so you will have to buy a needlessly expensive DAC.

Let me help you in this conundrum: I won’t break your DAC, so you can buy the Jr. at a nice price and have two beers all to yourself.

How’s that not an agreeable proposal?

Wow! What a kind offers! Thank you. LOL

I have an alternative idea… why don’t you fly over, tell my wife you broke my DAC (but don’t), and I use it (with the expensive PS) for the maximum credit toward a Junior, and then we go out and I’ll buy you as many beers as you want.


1 Like

Thank you for sharing the details of your network setup and the troubleshooting steps you took to discover the cause of the dropouts.

I concur that the DAC behaving inconsistently was because it was “voltage starved,” a term taught to me by an older engineer. He was also the fellow that explained the concept to me that a well-designed system “wants to work.” Meaning, the system is trying to do what it was designed to do and my job as a troubleshooter/repairman was to help it.

I have a number of non-hifi devices that use those adapters that make power supplies “universal” and I’ve had problems with them in the past. Your thread reminds me to start there.

Thanks again for sharing this experience.

Tom - glad you enjoyed it. And thanks for the additional confirmation that I’ve likely found the problem. :slight_smile:

Just to add to the record a bit, I’d like to add an additional bit of info. And apologies for not saying this earlier, but I shared SO much info, I was afraid for providing too much. But now I suspect its relevant…

I had another symptom when this started: frequency lock issues.

My DAC has a set of lights that indicate the playing music’s frequency. And when the music changes, there is an audible “click” sound. I suspect there is a relay in it, changing the electrical path when frequency changes. But no matter, point is… it clicks.

Before the drop outs started, my DAC began a habit of periodically clicking. And NOT when the frequency changed. I’d watch the frequency lights during the clicking. They would remain constant, indicating no change. Then the drop outs started.

And when the music dropped out, the DAC would click.

Based on what you’ve stated Tom, sounds to me like the DAC was “trying” to work, but having a problem. Could be voltage starvation indeed.

I’m just glad to have sorted out the problem. Thanks for the help folks.

Hello Scolley,

Thank you for using one of our products and we are sorry to read that you are facing issue’s with your MX DAC.

I came across your post and I noticed that you are using the wrong DC Plug for your MX DAC. The DC plug on the picture is DC plug #3 or #4 and for the MX DAC you have to use DC plug #2. This DC plug has a size of 1.3x3.5x9.5mm. The two supplied yellow DC plugs have a center pin of 1.7mm and will not make good contact.

Please change the DC plug to the correct type and inform us if the issue still occurs.

Enjoy more Music…

Wiebren Draaijer


Wiebren - thanks for the support. But I do believe you are mistaken.

The documentation provided with my SBooster lists around 200 different Brand/Models that it is compatible with. And all but 15 or so have information about which tip to use. Unfortunately the Musical Fidelity MX-DAC is one of those with no tip info. So I’ve tried every tip.

Tip #2 (black ring, 1.3x3.5.9.5mm) has an internal diameter that is too small. It does not fit over the pin. And an external diameter that is smaller than the #4 tip (yellow ring, 1.7x4.8x9.5mm) that I have snuggly fitting in the DAC right now. I’ve put - what I estimate to be - a pound or two of pressure on the #2, trying to push it into the MX-DAC socket. The pin hole does not fit. Too small.

So I’m using #4. Fits snugly on the pin - requires a small amount of pressure to slide it on - and does not wobble in the socket (#3 does).

Thanks for the help though.

Wiebren - I should also mention that while the documentation says the #3 and #4 pins are the same internal diameter, mine are different. The #3 fits a bit tighter on the pin than #4. It’s both harder to push onto the pin, and is a visibly hole larger to the naked eye.

Granted is could be because I’ve had the #4 in the DAC for some time now, and that hole may have gotten larger. But because #3 is more snug on the pin - and ignoring the fact that it wobbles a bit in the socket - I’m going to retire #4 for a while and see how #3 works.


@Wiebren_Draaijer - I tried that #3 for a while, even though it’s barrel diameter appears to be too small. It worked fine. Then I switched back to the #4, and the problem came back. It appears to not make good contact with the pin. As I mentioned - for whatever reason - the #3 fits more snugly over the pin.

Frustrated, I was relieved to recall that I have a typesetter’s loop. Here’s a picture of it over your adapter documentation.

And here’s a picture looking thru it at some text.

As you can see, it gets you down to hundredths of an inch - or even smaller - pretty easily. And from that, I can tell you that the barrel of the connector that came on my MX-DAC has an outer diameter of 4.75mm (call it 4.8), and the hole is 1.7mm in diameter. So my #4 adapter should fit perfectly. But it does not. It appears that the #4 adapter that came with my SBooster is has a hole that’s just a shade larger than it’s supposed to be.

I’ll drop you an email requesting a replacement.



Wanted to followup and give a shout out and “Thank you” to @Wiebren_Draaijer and SBooster. I requested a replacement tip. They promptly sent two different tips (just in case I guess) at no charge. And they sent a nice little bonus with it, I guess for the inconvenience. All much appreciated.

The new tip works great. Problem solved. Am now a Happy Camper. :slight_smile:

1 Like

@scolley - thanks for your detailed posts here - hoping you might be able to help me. So the connection between the cable and the barrel connector on my stock MX-DAC PSU is loose and I’m thinking it might be good to upgrade to an LPS at the same time as replacing. Just wondered if you heard much of a difference when you did? Was looking at - any immediately obvious reason you can see why that wouldn’t work? Unfortunately the SBooster is a bit more than I’d want to spend.

Was a bit confused by connectors as the manual states 4mm and you found it to be 4.75mm - I guess I’ll try a couple of different sizes. Is it centre pin positive?

Thanks for any help you can offer!