Need help troubleshoot arc settings for new setup

Roon Server Machine

NUC/ROCK

Networking Gear & Setup Details

  1. Who is your internet service provider? Testing Verizon wireless home internet

  2. Please list the make and model of your modem and router?

#1 Verizon Internet Gateway model # ASK-NCM1100
#2 ORBI RBR750

  1. Do you have any additional network hardware, like additional routers or managed switches? yes, I am using ORBIRBR750 and satellite to expand/improve my Wi-Fi range on property. I then have a couple of plug & play switches (I don’t believe they are ‘managed’ very simple one ethernet in, several out)

  2. Does your network have any VPNs, proxy servers, or enterprise-grade security? I do not believe I have any of these

Connected Audio Devices

DENON AVR-X4500H
DENON AVR-X8500HA
DENON DRA-800H
DENON SPEAKER 250
DENON SPEAKER 150 (x3)

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“75.aaa.ddd.eee”,“actual_external_ipv6”:“null”,“router_external_ip”:“192.168.1.151”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true}
}

You have two routers in your local network.

One router (The Verizon Internet Gateway) handling your internet connection which creates a LAN subnet on 192.168.1.0/24.

Then you have a second router (The Orbi) connected to the first which creates a LAN subnet on 10.0.0.0/24 (I’m guessing that you have not changed the netmask on the Orbi router and it is set to 255.255.255.0).

These two routers are creating the ‘MultipleNatFound’ problem which is what is preventing ARC forwarding from working.

You have, potentially, four different ways to solve this depending on device capabilities:

  1. Put the Verizon Internet Gateway router in to ‘bridge mode’ if it supports such operation
  2. Put the Orbi Router into ‘Access point mode’.
  3. Set up double port forwarding to match the double NAT that you have in your home network.
  4. Don’t bother with port forwarding at all and use Tailscale.

Solutions 1 and 2, both work by removing one of the NAT functions from your network.

For solution 3 you will need to:

  • Disable uPnP on the Orbi Router
  • Setup a manual port forwarding ruleon the Orbi to forward TCP connections on the port identified on the Roon Settings → Roon ARC tab to your Roon server on 10.0.0.1
  • Setup a manual port forwarding rule on the Verizon Internet Gateway to forward TCP connection on the port identified in the Roon Settings → Roon ARC tab to the Orbi router on 192.168.1.151

Solution 3, will also work better if you ensure that the WAN side ip address of the ORBI router and the ip address of your Roon Server don’t change either by DHCP address reservations in each of the routers, or by using a static ip address for the Orbi router and the Roon Server. In general, DHCP reservations would be preferred because it makes future network management (changing router for example) easier.

Solution 4 has recently become a Roon Supported solution:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.