Need help with HQPlayer run through Roon

So I bought a brand new MacBook Pro M1, and have not been able to get HQPlayer to work properly on it. On my earlier generation MacBook I had no issues. Roon and the player both running on the new Macbook. I am playing to a Yamaha avantage receiver through HDMI. Roon will play to the receiver directly, but if I select HQPlayer, it will not play to the receiver. I can get it to play through the laptop speakers, but not to the receiver. I have messed around with settings, deleted the program and reinstalled. Nothing works. Can anyone offer advice, I am really frustrated. Thanks in advance.

Have you made sure you don’t have the same audio device enabled as Roon output device?
In Roon Settings → Audio make sure you disable all other outputs than HQPlayer.

I swear I tried that. I will double check it. Thanks

Yeah, it doesn’t work. I knew I had tried that but wanted to double check. Any other suggestions Mr. Laako?

On the player I keep getting message at the bottom that says transport failed

Does HQPlayer play fine standalone, without Roon?

If that error happens when you try to initiate playback from Roon, it means HQPlayer is failing to connect to Roon.

It will play to the laptop speakers, but not to the receiver via HDMI. Same when I am utilizing Roon. I tried two different sets of HDMI cords just to be sure that wasn’t the issue, still not functioning.

And that receiver is not enabled in Roon as audio output? Or at least when you are trying HQPlayer standalone, Roon is running?

Please also make sure the HDMI output is not selected as default audio output device for macOS. And that it is selected as audio output only in HQPlayer, not in any other simultaneously running application.

I did not do that last part. I will try that immediately

Ok, tried it and still no luck. I made sure to switch HDMI cords again trying both with your suggestion and no luck.

Please enable log file in HQPlayer preferences, restart HQPlayer, attempt standalone playback and email the log file to me. It is located in folder “~/.hqplayer” and you can get there by using Finder’s Go To menu option.

which email?

Sent to

In Audio MIDI app, is your AVR configured for stereo or multichannel ?

I have it at 8 channel at 24bit 48Khz

Is that intentional? To play multichannel files?

So you’ve done that before with your previous gen MacBook?

HQPlayer set to 8 channels output etc?

that is the max option provided in the midi option menu, the higher rates are greyed out, even though the receiver I understand can accept higher

Yes but my question is why do you want max channels?

Are you playing multichannel music?

If not playing multichannel music, set to stereo.

Channel mapping may be an issue.

So progress finally, I have got Roon managing the HQP and playing through receiver now. The settings on HQP I am getting sound on are 8ch, 24 bit, max sample rate at 128k. Any idea or suggestions how to get it to play up to 192? I used to be able to do it on the old MacBook, and the Roon interface showed playing to 192 as well. Now it only shows playing at 48k.

I did try 2 channel and did not seem to change anything.