Need help with network path for NAS [Solved, SMB2 instead of SMB3]

I’m trying to add a network path in Roon, so it finds my music on a NAS. Long story short, I don’t have the luxury of just mapping the NAS as a local drive in Windows like I used to. So it has to be via SMB.

My NAS is an Asustor and I can’t find info anywhere about what sort of format the path would be. I’ve tried various things like smb:// or smb:// etc along with the correct login name/password. It seems to start searching but then gives me an error (I can’t recall the exact wording right now).

There is very little support out there for Asustor, certainly nothing like QNAP or Synology. I’ve asked this same question on the Asustor forum but doubt I will get much feedback.

If there is a directory called Music on the NAS then just use the “//” wording (no quotation marks). I always thought that SMB was an apple thing. You seems to have a Windows machine. Maybe.

Try something like \ \\Music And remove the space between the two leading “”

I just tried adding a network share on a windows core.


If this does not in your setup, I`d recommend checking the case-sensitivity of your shared folder. Also check if the user has the correct privileges to access your music folder. Do you know what SMB protocol version is used by the ReadyNAS devices?

Be sure to use the “Network Path” input field (not the first one labeled “Path”).

You can also check the connectivity to your NAS by accessing it with the windows explorer by entering
(note the backslashes here, in contrast to the regular slashes in the smb://… string)

Lastly check, if your firewall settings do not block RoonServer to access the NAS.

Got it - I had SMB2 in use instead of SMB3. Soon as I changed that, the original path of smb:// worked perfectly.

I think I had been using SMB2 due to some other application suggesting it for better compatibility, but I’ll gladly switch for Roon use. I’m very pleased with the configuration now. Thanks everyone for the suggestions!

That’s strange. I could use SMB2 on my Synology with RoonServer. I can’t test it on an Asustor but I’d guess it should work there as well…

Yes I’m not sure why that would be the case but I’ve confirmed it by going back to SMB2, in which case Roon loses connection with the NAS. Switch back to SMB3 and all is well.

Whatever the case I’m happy it is all working at the moment. Thanks again for the help.

1 Like