Need Help with Ropieee DigiAMP EndPoint Pls

I have built and loaded a DigiAMP+ RPi with latest Ropieee installed. I configured Ropiee, rebooted Roon Core and Control, confirmed that the unit is on the same subnet, etc.

Here’s the thing: Roon “sees” it in its About Window:

but it is not showing as an enable-able item:

Here’s the rest of the enable window:

(Refresh buttons used several times; core is an Intel i7 NUC ROCK; other specs in profile)

Obviously, I’m missing an important, probably simple step. Any ideas appreciated.

Here are the Ropieee specs for the record:

Does it work with DHCP instead of static IP?
Looping in @spockfish for help.

Can someone move this to the ropieee thread?

I think the AMP+ is not being detected as a device that is capable of audio output so try defining the AMP as a DAC+ instead. (I had the same issue when trying to get my AMP working with dietpi a couple of weeks ago)

Do you have a firewall running? If so, turn it off and check again. Then turn on again.


Can you send me feedback?
After you tried @John_Mason’s tip, because I’ll bet my money on that :wink:

regards Harry

Feedback 39dc5c4c1bdec78f

Although I worked quickly, increasing possible errors, I tried all three of the IQAudio choices, rebooting Core after each switch, with no joy.

Thx for the suggestion, Martin. No firewall present.

Did you use a non-IQAudio configuration? If so, which one?

hi @John_V,

Indeed the device is not properly being identified during initialization (it produces errors).
Have you tried removing and attaching the HAT again? Sometimes that helps…

what configuration should I use (need to reset it)

@spockfish just power cycled Ropieee with DigiAMP+ configuration. Genrated feedback:


No status change. Reflash now??

Same problem.
No need to reflash. The hardware is just not being initialized properly and returns an error.
Are you sure this is a working unit?

Well, no. Just unboxed it. There are some troubleshooting systems on IQ. Think I’ll flash one of those next.

Yes (sorry) I am using a hifiberry AMP2 (they all have confusingly similar names) but your symptoms appear to be the same as when I have mine defined (in dietpi) as AMP2 when it needed to be set to hifiberry dacplus (as it is the DAC onboard the amp that roon needs to communicate with)

thanks much for the idea, john. so far, i’ve tried out the other IQAudio configs but still no recognition. Time to contact IQ, methinks.

Update from the OP: first, I continue to be impressed with the breadth and depth of knowledge in this community as well as your willingness to share it. Many thanks.

The ending, or at least stopping point, is a mixed bag. I had bought two DigiAMPs, and wrote about the first one I assembled (see above). Then I assembled the second one, installed Ropieee, configured, and, with one hiccup, it worked and continues to work.

@John_Mason’s suggestion to try a different config was a good one. When I first configured AMP #2, Roon AGAIN failed to recognize it. I then temporarily switched the configuration to IQAudio DAC, and Roon then “saw” the endpoint. BUT… Roon thinks it is now a “IQAudioDAC” and not an “IQAudio DigiAmp+” as I proscribed. So, @spockfish, methinks the DigiAmp+ config needs tweaking.

I have written IQAudio about the problem, inviting comment, and haven’t heard anything. Their banner says they are in “Stock Take” (a.k.a. taking inventory) until November 5th (!) I hope that they will respond to email. But maybe not. I’ve written five emails over the past few months; no response.

I am not looking forward to the refund experience. Their website says that, if a returned HAT “tests okay” when they get it, you get No refund AND a bill for the return postage. I might spend $50 returning a 42 pound (sterling) card, with no assurance of receiving anything. Hmmm…

Thanks for all the help.

Perhaps @Gordon_Garrity might be able to help in regards to arranging a return?

It seems like you’ve narrowed it down to a hardware problem but you could always try flashing Volumio to a separate SD card just to be sure?

1 Like

@John_V Good to hear you have at least one of the amps working.

It’s odd that 2 different AMP manufacturers and 2 different pi distributions both have issues when you select their “amp” config instead of of the DAC. I mean it makes sense, as the data does go the DAC and the amp part is essentially invisible to the driver (I would have thought) but the config files need to reflect this.

It’s a tough call about sending it back. If I were in your shoes, I’d be tempted to take roon out of the mix, copy a track to the SD card to playback locally and collect console output from amixer and aplay to demonstrate how it works with the one device and not the other (if not for your own piece of mind).

btw, my amp has been mounted inside my granma’s old Bush valve radio to make a hipster endpoint for the kitchen. :slight_smile:

Have been in touch these past few days asking for the configuration to be simplified and trying our quicktest images.

We have so few failures on outmr hardware we find majority of issue are software config.

We are always happy to exchange any board that fails but first it’s simple to ensure it’s not a software issue - especially when we test each board before it’s shipped.

We suggest you try quicktest image.

We suggest you use our official Roon Labs RAAT image over any roon bridge configuration.

If we can get feedback on the standard quicktest image then we can start to identify the next steps.

Hope that helps.


John, we’ve replied to every email you have sent. Maybe check your spam folder?