Neither nor Pixeel 4XL remote will connect to core

Core Machine (Operating system/System info/Roon build number)

MacBook Plus (Mid 2012) Catalina 10.15.7 Roon V 1.7, Build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi, Netgear AC1900 Range Extender

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lumin D1, Wifi

Description Of Issue

I ave tried connecting a 2019 iPad Air and a Pixel 4XL to the Roon Core on the MacBook. Neither would connect. I’ve turned off the firewall and verified that “Accept connections from remotes” is On. I can play music on the Lumin from the MacBook with Roon.

What’s the brand and model of primary WiFi router? Also Netgear?

How is the Range Extender connected to the primary WiFi router? WiFi or Ethernet?

Your WiFi network is not passing multicast packets, causing this discovery issue. This is usually related to IGMP settings in Netgear. Also try disabling Smart Connect.

My advice ditch the Netgear and range extenders and set your self up with a decent WiFi system. Something ideally you can hardwure the access points or use a mesh system that’s known to work reliably. The Netgear and using an extender is the root of the problem.

Netgear products are useless with multicast data, which Roon and other devices software rely on for discovery. I have a Pixel 4 and it finds my core with no issues at all.

A few years back I had a Netgear R8000 and had nothing but trouble with my Android phones connecting to the core. It drove me mad. I decided to buy a seperate WiFi endpoint to try by a company called Unifi and turned off the WiFi on the router. This instantly improved things. I could connect easily and it stayed connected. Since then I have built a network from all unif gear and it’s pretty damned rock solid. It covered the whole house with multiple endpoints each are wired back to the main switch which also provides power to them over ethernet making for a neater solution and no extra PSUs.

I know it’s not what you want to hear that you need to change how your network is, but trust me this is the cause of it combined with Androids flakey network Stack.

Hi @J_Mill,

Were you able to successfully connect your devices to the Core?
What happens if you try to bypass the range extender, does the connection then work?

Sorry it took so long to reply. I moved the Roon Core from my MacBook (which is in the living room with the stereo and Lumin D1) to a PC. Everything then worked. I could use the Roon interface from the MacBook or from my iPad in the same location… This suggested that the problem was not the extender.

However, for no apparent reason, Roon on the MacBook and iPad became unable to locate the core in the room with the stereo, but the iPad continues to work when in the same room with the PC and the router. The Lumin app still works fine.

There are three different networks to which I can log onto. First is the Netgear in the living room. Second is an Amped extender in another room. The third is a Verizon extender that is hardwired through a cable TV connection to the Verizon router. None of these connections enable me to find the Roon core, but all work with the Lumin app.

I’ve measured the signal strength using an Android app, and they all report a bitrate in excess of 100 mbs.

What I find most mystifying is that it suddenly stopped working.

How fortunate we are to have computers to keep us busy fixing problems!?

Signal strength or speed has nothing to do with discovery. It’s always related to something on the network blocking or not forwarding correctly multicast data from Roon. Lots of domestic kit does not do this well. The more bits of disperate network hardware you add the more this is likely to happen and harser is to trouble shoot.

Thanks for your reply.

I would think that then connecting to the Verizon extender would work, since it is physically connected to the router and in theory looks to the network as it it were the router.

The fact that it worked for three weeks and then decided to go on strike is curious.

To me this sounds like DHCP issue of some kind. In your network only one device should be controlling DHCP addresses and that normally is your router. Make sure these extenders are connected using using DHCP and they extend the network doing the same. They need to get assigned an IP address from your router. If you have multiple devices handing out DHCP it will cause all sorts of issues and likely you have wireless devices running essentially two different networks.

Please reserve IP addresses in the router DHCP reservation table for all Roon-related devices.

After the above change is saved, please power down all your network devices including computers, Lumin, iPad, all the extenders, and the router.

Please power up the router. Wait for 5 minutes, then power up the extenders.

Wait for another 2 minutes. After that, then power up everything else.


Thanks. I’ll try this and let you (and anyone else reading this) know what happens.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.