Network share address for a backup to an external drive

Can someone please advise what my network share address should be to add a Roon Database backup location from my Nucleus+ to an external hard drive.

I’ve tried using the smb address and got an error message.

Is the external drive attached to the Nucleus or the Mac?

If it’s on the Mac, then this should help. It’s the same method as adding a music watched folder.

Hi Greg,

I received a network path error message.

This is what I used, smb://Pauls-MacBook-Pro-3.local

What’s the name of the target folder? I see Internalstorage, Paul Elliott’s Public Folder and Storage.

Then it would be, for example:


If you did that, then try smb://

I tried both and received ‘unexpected error’ message

Hello @Paul_Elliott,

Try adding your Music folder to the “Shared Folders” list in System Preferences and then adding smb://your-ip-address/Music in Roon. If this works, you are likely hitting this broken “feature” in macOS 10.15 Catalina:

To resolve this issue, try the following steps:

A. Open Finder.
B. In the menu bar, click “Go” > “Go to Folder”.
C. In the folder prompt type /usr/sbin/ and then click “Go”.
D. Locate the “smbd” file in the folder.
E. Open System Preferences > Security and Privacy > Privacy > Full Disk Access
D. Drag the “smbd” file from finder to the System Preferences list for apps given Full Disk Access
E. Restart your Mac.
D. Once your Mac has rebooted, attempt to add the directories via SMB again.


Hi John,

Thanks, that worked.

I tried to set up the LaCie external drive as a new database backup location, but Roon couldn’t see the RoonBackups folder on the disk.

But here it is when I select the LaCie from the Mac

I’d previously dragged and copied it from the Nucleus to the LaCie.
Does this mean that I have to let Roon setup a new RoonBackups folder rather than use the existing one?


Sorry, I realise that I had the wrong path, now I see what I did wrong :slight_smile:

@John Roon labs support

Hi John,

Sorry but now Roon can’t see the folders on the external hard disk. Can you throw any light on this please?

Many thanks


Hello @Paul_Elliott,

I just tested adding an external drive attached to a Mac running Catalina to a Nucleus and was able to do so without issue.

The first thing I would check is that the “LaCie” has been added as a “Shared Folder” in System Preferences > File sharing.

As a troubleshooting tool, I would try mounting the smb://ip-of-computer/LaCie share on a different computer to see if this issue reproduces elsewhere.