Network upgrade/tidy up

Today I finally finished sorting out the house end of my network setup. Up from 20 cabled devices to 34 (new patch panel required😏), swapped out my old Ubiquiti USG + Cloudkey Gen1 for a Ubiquiti UDM Pro and built everything into a home-made, welded alu chequerplate network housing with temperature controlled cooling fans and air extraction.

The entire setup is shoe-horned into the kitchen understairs pantry cupboard, so a proper network cabinet wasn’t possible. I had to get creative and custom make my own enclosure to fit the space.

Unfortunately this also meant I had to disconnect and re-terminate the original patch panel to fit it in the new enclosure.

Out of 296 total terminations, I only had 3 which hadn’t quite seated properly (1 in each patch panel and 1 in a module in my wife’s office) and needed to be punched down again. Where would we be without network cable testers?!

Old setup:

The original Cloudkey Gen1 had a habit of messing up its database every 6 months or so requiring a hard reset and restore from backup, and the USG’s intrusion prevention (if enabled) limited bandwidth to 85Mb/s.

The UDM-Pro with intrusion prevention enabled still lets me max out my 570Mb/s internet connection and so far, I’ve had zero issues.

New setup:


A magnificent effort. You sir are the Lionel Messi of home networking.


Thank you! :relaxed:

Despite having a very good Wi-Fi setup (3 x Ubiquiti UAP-AC-Pros), I still have a love/hate relationship with Wi-Fi, so I run cable to everything that has an ethernet port. I’m also a total neat-freak where cabling is concerned, hence the colour-coded patch leads and cable identification numbers :nerd_face:


BTW, for anyone who is into rack-mounting their networking or hi-fi gear, I can thoroughly recommend Rackstuds

They’re light years ahead of cage-nuts in terms of functionality and ease of use.

Love the sardine can. Fitting somehow.


Very impressive, but you left out the most important bit. Why didn’t you mention the ‘veils lifted’, lower inky black noise floor, more PRaT (only applies if you own Naim gear obviously), higher highs, lower lows etc etc.
And just you wait for the massive improvements once it has all been ‘run in’ properly. :rofl:


No doubt someone, somewhere, will be wondering if there are any “sound quality” improvements :rofl:


The golden rule of tweaking seems to be that if you’ve spent any time and money on it, there is always a SQ improvement. The ‘I tried an audiophile switch/Ethernet cable/PSU and it made zero difference’ accounts never seem to get reported…


I just ordered a cloudkey gen2 plus, USW16 Poe, and a WiFi 6 AP so I can extend to the new garden Room office. Went for the cloudkey plus as I want to get some unifi cameras setup as well. It won’t be as neat and tidy as yours when I’m done.


Wonderful job Graeme, looking very neat and tidy. That’s mid size office level of gear and number of sockets as well.

Hopefully that will take you forward to having more Roon zones in the house :grin:

1 Like

Keep an eye on the memory utilisation on the UDMP … creeps up into the 90’s after a while…best to do a console restart when it gets to 90+%

1 Like

Good work…!

1 Like

Thanks.Yes, I’ve noticed that memory use seems to creep upwards over time.

Just found a little trick on Reddit. You can SSH in to the controller and restart the unifi-os without losing connectivity:

podman restart unifi-os

Dropped my memory use from 70% to 35%.

Apparently it also helps to kill any services not being used. I don’t use Protect, so I stopped the service from within the Portal.


Unifi works well with Roon, except for something that previously did not happen to me with the tp link switch. I have a Unifi 8 poe 150w + flex mini switch and when I restart the whole system the connection with the Nas is lost. My configuration is as follows. Amplifi Alien Swicth + Wifi + VPN - Switch Unifi 8 Poe 150w - Flex mini. Nas Asustor As7004t - Ropieee (NAA) - Roon core Rock i7 10gen Akasa passive - Nuc i7 10 gen HQplayer Desktop. Everything possible is configured with static IP, in the absence of the ports of the Unifi switches that cannot be put in static without a USG or Dream machine. I think this is the problem of loss of route between the Nas and the core, I have to put the route back even if it is the same. They can clarify something on this subject. Sorry for the English. Thanks

Is your NAS’ IP address set as a DHCP reservation in your router?

I would always use a fixed/static IP address for servers / printers/ and other devices that are cabled. if not at least a DHCP reservation at a bare minimum.

1 Like

Cool…must try that one next time I need a fix…interestingly its still in Green at up to 95.x% then goes to amber level warning colour at 96% I think.

USW 16 PoE and CloudKey Gen 2 Plus all installed today in readyness for the garage to be finished end of the month. Had a bit of a nightmare switching controllers as I have been running it on my nas and for some reason I could not get a backup out of it to setup the cloudkey. Also had manually update controller on the cloudkey to the latest version as it would not auto update. Got their in the end.


I had a few niggles getting a backup out of the CloudKey Gen1 and uploading it to the UDMP. Couldn’t download a backup, so had to pull out the MicroSD card, do a factory reset, put the card back in and restore it before downloading the backup to my PC.

Then had to update the UDMP to the latest controller version before doing a backup restore.

Still had to tinker afterwards as the UDMP didn’t seem to understand my previous Guest Wi-Fi network setup, preferring instead to try to configure the guest portal on the main Wi-Fi.

Like you, I got there in the end though :grin: