Networked PS Audio DAC Still Not Appearing


I was up and running after install Roon last night. Tried to bring up the program and get the music going, and my DAC has disappeared from the network devices option.

My setup is Roon Core (on Mac OSX 10.11.6), QNAP NAS (library) linked via ethernet cable to router, and router to PS Audio Directstream via ethernet cable.

I have turned on and off the PSA Directstream. Still nothing appearing on Roon.

Thanks for any help in getting back up and running.


Your DS DAC needs to have the bridge 2 update and Torrey’s firmware. Without both of these it won’t be recognised in Roon

I should have been more specific – all updates have been installed.

Everything worked perfectly last night. The problem is that today the Directstream disappeared.

Are you using fixed IP address? Double check your cabling and see if you can ping the ds from the server

Try using something like fing on a mobile to see if you see the IP addresses you expect.

Same IP as last night. Appears on the network.

Does anyone have further insight on this issue?

Last night, after about 30 mins, the PS Directstream re-appeared on the Roon device options.

Today, it has disappeared again.