NetworkError (The remote server returned an error: (405) Not Allowed.)

Core Machine (Operating system/System info/Roon build number)

Synology DS218+, just updated to the latest firmware (DSM 6.2.2-24922 Update 2). The Core is on a docker container, via steefdebruijn/docker-roonserver. Remote on MacOS and Android.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Nas is on ethernet, remote on wi-fi. Routeur is Livebox Orange. Audio device is on wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RaspberryPI3 with HiFiBerry Dac+ plugged (RCA) on my sono system.

Description Of Issue

Since i’ve upgraded to the latest Synology Firmware, i can’t login to my Roon Server on my different remotes. Even if i put the right credentials, it says “Network error, please check your internet connection”. If i shell into the container to see the logs, here’s what it says :

07/13 12:42:29 Trace: [fiveaccountserver] POST
07/13 12:42:29 Trace: [fiveaccountserver] BODY email=**************&password=<<<PASSWORD>>>
07/13 12:42:29 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=<none>
07/13 12:42:29 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
07/13 12:42:29 Trace: [push] retrying connection in 29716ms
07/13 12:42:29 Warn: Error in web request NetworkError (The remote server returned an error: (405) Not Allowed.)

(FYI I edited the email in the log)

Can you please help me?


Hi @Enorme_SoixanteDixSe,

Since updating the Synology have you tried giving it a reboot?

Are your remote devices able to connect to the Synology outside of Roon?

Hi Dylan,

yes i’ve already reboot my Nas, and the core also.

And my remote can access to the nas without any problems.

Hi @Enorme_SoixanteDixSe,

Are you by any chance running any new firewalls on the Synology? From the trace you posted, it appears that access to our Roon servers is being blocked somewhere along the line. I would also make sure that you do not by any chance have Open vSwitch turned on in the Synology config settings.

The only thing i’ve done recently is updating the firmware of the Nas.
And, nothing, in the new features, seem to be related to any firewall…
Open vSwitch was turned on, i switched it off, reboot, but nothing change.

Hi @Enorme_SoixanteDixSe,

Thank you for confirming that aspect, I have a few further questions:

  1. Is this behavior still occurring today or has there been any change?
  2. Can you share a screenshot of your current docker settings for the Roon app?
  3. Does Roon behave as expected when you bypass the docker install and have it natively installed on your Synology via the app store?

Hi Noris,

Here are my answers :

  1. Yes, it is
  2. is this ok for you or do you want something more specific ? //
  3. yes, with a native install on my nas, everything is ok… but i really need to have it on docker.

Thanks Noris !

Hi @Enorme_SoixanteDixSe,

Thank you for letting me know that the native install works as expected and that this issue is limited to just the Docker install. I will discuss your findings with our technical team and will reach out to you again once I have further feedback.

Thanks Noris :slight_smile:

Hi Noris,

It seems that i’ve messed with DNS Server and other stuff like that on my Nas. Everything is working like a charm now :slight_smile:
Sorry for my request !

1 Like

HI @Enorme_SoixanteDixSe,

Glad to hear that the issue is resolved after updating the DNS Server in use!
No worries about the request, happy to help.

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.