Networkshare for back-up failed

Hey,
After I succeeded twice in creating a network share for backup, I am now unable to do so. Because a disk with Roonback-up caused problems, I deleted it and wanted to add another disk with folder. This is no longer possible while I am doing the same as with the previous folders where it worked. I made some screenshots:
The drive shared:


Folder shared:

Result:

Successful result with a different drive and folder:

What am I doing wrong that makes it impossible now? I have already tried it with 3 other drives with backup folders, but the result remains the same. Even if I omit users name and password, the same happens: not authorized.

Greetings, Bert Dijkstra.

Hi @Bert_Dijkstra,

Can you provide some details on your Core machine and your network?

Were there any OS updates on the Core machine recently, around the time this started?

Any change if you disable any firewall or antivirus?

Hello Dylan,

My Core machine is the sonicTransporter i7 which is connected via a switch to the modem/router Connectbox the Arris TG 2492LG and the Fritz!box 4040 router. The last two are connected via the same switch and are set up to form a single network. Both devices have a router function and the Fritz! Box provides the WiFi, because my iPad with Roon Remote had connection problems so I opted for this solution with a PC service.

There were some OS updates but not specific around the time this started.

Changing firewall or antivirus didn’t have any result.

Furthermore, I have set the deleted disk for network share again today and that goes smoothly. On the screenshot that I have attached below it is about disk J (music library Günter). The disk that does not authorize is disk H, while the screenshot shows that that disk is shared.
verkenner

Greetings, Bert.

Hi @Bert_Dijkstra,

Justo to make sure I’m understanding correctly — The J: drive is working fine, but the H: drive on the same machine is not, correct?

Is there any difference in how the J: and H: drives are connected?

Can you share some screenshots of the H: drive’s share settings?

Hello Dylan,

Yes, on the same machine and on the same USB hub (powered). I can add J: drive to network share and it is accepted. I removed this drive from the backup Roon list on Monday because the drive caused problems on my PC (USB device not recognized and 10 minutes later recognized etc.). But to see if I could add it again, I tried it today and yes, I could add it again. This failed for three other disks. So today I tried to add H: drive to network share. Below the screenshots with the result:

drive shared:

folder shared:

result:

The settings for all the drives are the same but only drive J: and M: are accepted.

Greetings, Bert.

Hi @Bert_Dijkstra,

How is the H: drive formatted? Is it different than the other drives?

Hello Dylan,

Drive H: and D:, not accepted, are NTSF formatted, so are drive M: and J: in the same way formatted and accepted for Roon backup.
There is some other thing that you can see on the screenshots: the authorizations for the new folders with Roon Back-up do have numbers, Backup Roon 2 for drive D: and Backup Roon 3 for drive H: , maybe not important but I didn’t give that numbers.

Hi @Bert_Dijkstra,

Do you have another device that you could connect this USB drive to? Its looking like there is something specific to this drive that is occurring, but it might clue us in to what is actually happening if we were to be able to make this connection when it’s connected to another machine.

Hello Dylan,

Thanks for the tip. Last night I connected drive H: to the laptop and was able to add it to network share without problems. Immediately afterwards done the same on my PC but unfortunately. Even after turning off my firewall and my antivirus software, it didn’t work. It is unclear to me why my PC is preventing authorization, while it worked for the first two disks.

Hi @Bert_Dijkstra,

Thanks for the details here. So it seems like everything is okay with Roon’s ability to connect to the drive from another machine, so something specific to the configuration of the original machine is likely causing some issues here.

As a test, can you try connecting to the H: drive from outside of Roon? From your laptop can you connect to the drive using the same path you’re entering into Roon? Does it work okay?

Hello Dylan,

I’m sorry for late reaction but it was a busy time for me. I hope to do your proposal this weekend. After that I will report.

Greetings, Bert.

1 Like

No worries, @Bert_Dijkstra. Just let us know when you’ve had the chance to do this and we’ll go from there. Enjoy your weekend!

Hello Dylan,

I was also unable to access drive H from my laptop. Through properties and security of this drive I made adjustments and then this happened:
Drive H: is seen. I had never come to that before.


I can see all folders and choose folder Backup Roon.


I can add a Scheduled Backup.

But if I choose Save …

Unfortunately, no access at last. That is a setback. I had never come this far with disk H :.
However, I can now access drive H: on my laptop and open folders. I learned that anyway.

Greetings, Bert.

Hi @Bert_Dijkstra,

To recap:

  • No change if you disable firewall and antivirus
  • The J: drive on the same USB hub is working fine
  • The J: and H: drive are both formatted as NTSF
  • The H: drive can be added from your laptop over the network but not the PC it is normally connected to
  • You can connect to the H: drive from the network outside of Roon
  • You made some adjustments to the H: drive’s settings and were able to connect, but not add it as a backup

Can you elaborate on the settings that were changed here? What is different now that allowed you to connect?

Hello Dylan,

I don’t remember exactly but at disk H:> properties> security I missed “Everyone”. I had added it and given permission for all actions.
Today I went through with it again and now have disk H: and disk M: compared in detail both sharing and security. I am now almost sure it is all right. I did notice that with disk H: settings were not made for Everyone, both in share and security. Forgot to allow something? To be on the safe side both disks closed and restarted to see if all settings are the same and unchanged. They are now. Also in security> advanced.
I will now check again if I can make a backup in disk H :.

Yes, it worked. What did I learn? So you not only have to check everything for share of both disk and folder, but you also have to check everything for protection> advanced and you need to see share and full management. You should also check whether your adjusted settings are actually implemented. I did that by closing both disks and turning them back on. If you forget something somewhere, it will not work.
Well this problem has been solved. Thanks to everyone who provided advice and assistance.

Greetings, Bert.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.