New Allo USBridge - no output

I received a new Allo USBridge today and got it out of the box and connected up just fine. I can see it on the network and configure it just fine. I can see it in Roon and have it set as the active device. I am playing to it and see the progress bar at the bottom which indicates it’s playing however no music comes out of the speakers. My config is the USBridge via USB to a pair of KEF LS50W speakers. My microRendu plays just fine in this setup. All I did was swap one for the other. Can’t understand why no music. Any ideas?

Which OS are you using?

Oops. It was me. I had the wrong config in Audio devices. The problem was between the keyboard and the back of the chair.


Okay I have been working this all day and finally got it to play via USB to my KEF so now I know it works. Lots of reboots and experimentation. So here is where I am now. Now that I know the USB output plays music via Roon I installed a DragonFly Red to the output of the USBridge and now all I get is clicking when I connect it to the analog inputs on the LS50W. No music. Just clicking. Does the USB output of the USBridge support the DragonFly Red? Anyone else using it this way?

In case it helps someone I solved the DragonFly Red issue on my USBridge. You need to switch the DAC in the GUI to USB 1.1. This solved the clicking issue I was experiencing. The answers are out there. They just take some research to find.