New Amazon 8 won't let Roon "stay awake"

Hi chaps,

Been with Roon for a few months now and loving it. You guys helpe me set up my NUC a while back and everything is as sweet as!
Got myself an Amazon HD 8 this week as a dedicated remote which works except it won’t keep the Roon screen (playing now) awake. I have activated it in settings / setup but afetr a while it returns to the amazon home screen. Any clues how I might rectify this?

Cheers, Tim

Have you pinned the roon app?

Hi Ged, you got me there…what is “pinned”? I’m learning but that one got away.
It is a bit random atm.

Go to settings, security & privacy and select App Pinning.
Then with roon app loaded tap the Task Switcher, the square on the bottom border. The app will appear in a smaller window click the roon logo.

Then select pin.

To unpin an app, hold the Task Switcher and the Back arrow down at the same time.

Ok that’s clear thank you. However looks like Amazon HD 8 is missing that option. It isn’t under security and privacy on my device.

Switch on parental controls and it should be in there.

To take a screenshot press and hold the power button and the volume down button together.

Ive hot an hd+ so its not exactly the same

Not showing there eithr, just Household profiles and then if I turn that on i only get to add a password.

Must be an older version. Have you got the latest available updates on it?

Yep, latest update but it is a 7th gen, maybe that’s it?

Yes i think so. Maybe i should sau, i don’t know enough really.

Hey Tim, Look for the “Advanced” section within “Security” to locate the Pin control setting. Once you have allowed pinning, open the roon app and follow Ged’s instructions to pin and unpin apps.

Hi John, the advanced section seems to be missing (see photo above).

See if this helps…

How to pin the screen on an Amazon Fire HD 8?

Had a look but that looks more like my samsung phone :wink:
I’m running Fire OS, the latest.

Curious thing is though I’ve turned off Adaptive brightness and the screen seems to be holding now. I’ll let you know if that has cracked the issue.

Thanks so far for your help:)

1 Like

See if the ability to pin apps is already activated by opening the roon app and following Steps #7 thru #10 from the link I provided.

Tim, I’ve got the same problem. Older HD8, seems to be no way to pin the app.

1 Like

That just opens the screen again…