New Arc Setup - All Ports are forwarding to the CORE

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“23.aaa.bbb.ccc”,“router_external_ip”:“98.ddd.eee.fff”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.4.1”,“found_upnp”:true}
}

@Anthony_Burley, I moved your post to the Port Forwarding section so the community and Roon staff can better support you.

Can you you please fill in the additional details above to provide additional information and context to what you are seeing with ARC?

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.
Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridge mode and if not, try to place into Bridge mode
    If you continue to experience difficulties, please tag the support team and include the following information:
  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
    Thanks!

I am using a Comcast Supplied Modem - Technicolor Model DPC3941B Port Forwarding from the Modem to on Port 55000 to a Eero Router.

Eero Router has Port Forwarding to a PC with an internal nat PC with an IP Address of 192.168.4.41 on Port 55000. The Eero is configured to make the 192.186.4.41 a Static IP and this is the current ROON Core IP.

Those settings also would be my recommendation (Comcast gateway port forwarding → Eero router port forwarding → Roon Core), so not sure what else is happening. Have you made the port forwarding rules to cover a range of ports (e.g., 55000-55010) in case the Roon Core resets these? My ports have has moved occassionally across 1-2 port numbers, so I have a range I use in the forwarding rules.

I have two NIC Cards in the PC where the Roon Core is installed. Both NIC Cards have Static IPs reserved via Eero’s DHCP service

The Eero is setup to send all port 55000 traffic to both NIC Cards with the Static IPs reserved via the Eero’s DHCP service
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 23.aaa.bbb.ccc:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“23.aaa.bbb.ccc”,“router_external_ip”:“23.aaa.bbb.ccc”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.4.1”,“found_upnp”:true}
}

Darn…its my fault. Windows Firewall was blocking it

So are you back in business?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.