New install can't find NAS

Core Machine (Operating system/System info/Roon build number)

MacOS 10.12.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Lenovo NAS cable-connected through switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Roon can’t find the music share, even though it is mapped by the Mac. I am seeing error message: Unexpected Error.

Roon version 1.6 build 416

I have tried:
\server\share …double blackslash here before server name!
\IP Address\share …double blackslash here before server name!
smb://NAS IP address/share



On your Lenovo NAS, is SMB 1.0/1.1 enabled?

Hi @Lee_Hammond,

In addition to @Mikael_Ollars suggestion of having SMBv1 enabled on the NAS, can you check to make sure that you have allowed Roon past the OSX firewall (and past any other firewalls you may have on that machine)? You can use these instructions from Apple to verify this aspect.

Thanks for the rapid response, @noris and @Mikael_Ollars.

I can connect to the NAS, using smb notation as shown in the screen cap, from the Mac, so I assumed it was enabled. I confess I don’t know how to disable it. Lenovo is not updating support for this NAS any more. For comparison, iTunes can see the NAS but can’t successfully browse all the music.

The MacOS firewall is not enabled.

I copied some music content locally, to get things moving with the Roon software. So far, I am really impressed with ease of use and flexibility. Maybe a large, single disk would be easier for the music library.

HI @Lee_Hammond,

It sounds like there might be some issues with the NAS communication itself if iTunes is exhibiting similar strange behavior. I am not sure if there is a “Web Config” page for the NAS, but if there is I would double check the SMB settings on it.

Glad to hear that the secondary method is working so far! For ease of use, you may want to consider using the external drive as you noted, otherwise you may have to do some more troubleshooting with the NAS’s SMB connection and also verify that there isn’t by any chance other firewalls blocking Roon’s access to the network (even AV firewalls such as McAFee/Bullguard/Little Snitch/ect.)

Do let me know how it goes!

The NAS is connected to the Core Mac through a switch and both are cabled, so no firewall is involved.

Somewhat weirder, as a follow-on here, I was reminded to back up the Roon Core today. I tried to back up to the same NAS, different share, and it worked fine as far as I can see. I used the same smb://NASname/sharename notation.

Hi @Lee-Hammond,

Just to make sure I understand you correctly here, share1 which contains the music is not accessible, but share2 which contains the backup location is? If you transfer a few media files from share1 to share2, are you able to properly add these files to your Roon install? I wonder if this issue is limited to just share1 and if there is something preventing the proper access of that share.

I said it was weird. Yes, I put some music in the second share and it was imported. I checked the permissions, for the two shares, and they are nominally the same: read/write for the account being used. I’d expect read only should be enough, no?

I’ve copied all my content to a local drive. The whole library is not so big, at about 50GB. It was on a NAS mainly as a backup, as it has raid 5.

Hi @Lee_Hammond,

I would expect read only to be ok if you are not writing to the NAS. It is certainly strange that share2 worked as expected while share1 didn’t, I wonder if there were some other hidden permissions for that first share that were disabled?

Either way, glad to hear that you have managed to copy your library to the local drive and that is working as expected. If you have any further issues in the future, don’t hesitate to reach out to us again. Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.