New install - USB drive problem

I have worked through the installation of Rock on a new NUC713.
I can access the ROCK core from a Windows PC and everything looks fine.
I cannot get the ROCK NUC to recognise the USB 3 4TB drive containing my library but it will recognise another, smaller, drive.
Both drives mount just fine on a NUC running Win10 and I am able to access the content.
So what is going on with this NUC/ROCK that it cannot even let me add the drive as storage?
Thank you for your kind assistance.

What format is the drive (NTFS, exFAT etc)? ROCK supports virtually every format though. I use ROCK with a 4TB USB3 drive, formatted as exFAT without issue. Have you tried another USB port?

The drive is formatted for NTFS.
I have tried a front and a rear USB port.
As I said, the drive mounts just fine on a variety of Windows computers.
Thanks for the help.

When I use Roon Control on a PC to manage the Roon Core on the NUC, I go to Storage / + Add Folder / Folder Browse and no choices are displayed no matter what USB port the drive is connected to.

Have you tried a different USB cable and power supply? What make of drive is it? Other than that it is time to call @support .

The USB is self-powered and, yes, I have tried two cables.
The USB drive has no problems being mounted by a Win 10 NUC and it shows that folders and files as expected. I can play those files just fine through another program.
Prima facie, it seems as if the drive and its contents are in good order.
Either there is a hitch in ROCK or ROCK does not like 4TB self-powered USB drives in NTFS format.
I will send a message to support. Thank you.

New install of ROCK on a new NUC7i3, 16GB RAM, 275GB M.2 SATA.
Updated BIOS
Everything seems to be fine except that I cannot get Roon to recognise a 4 TB self-powered USB drive, NTFS format with 100,000 FLAC files. That same drive has no problem being seen by Win10 or MacOS and the files are playable.
When I use Roon Control on Win10, Settings, Storage, Add Folder, Browse this is what I get:

, Whether I plug in the drive when the ROCK is on or I start the ROCK with the drive plugged the result is nothing. Front USB ports, rear ports there is no difference.
At this point my project has stalled until I can have a solution to the USB drive recognition problem.
Please let me know what I have done wrong so that I can get started with ROCK.

I’ve moved this thread across to the Support forum, and flagged @support for you.

According to the Nucleus manual, your Roon Core running on ROCK should be able to read an NTFS-formatted USB drive, so something is amiss somewhere.

I wonder if the USB port on an NUC hasn’t got sufficient power to handle your 4TB drive? I’ve seen this happen on a Lenovo tablet, where the port was underpowered, but I’m surprised if it is the case for an NUC. What’s the brand of your drive?

Thank you for taking care of getting the message to support - I obviously messed that up too!
The drive is La Cie.
I have two other NUCs and the drive works with both of them just fine. So, there may be something wrong with this NUC but the previous experience I have of this USB drive is that it works as is just fine except on the ROCK NUC.
Hmm, that makes me think there might be something in the BIOS. I reset the BIOS per the instructions but maybe…

I checked BIOS all the USB ports are enabled and powered.

Hello @Peter_Davies1,

Is the NUC able to see other USB storage devices such a thumb drive or a different external drive?


1 Like

Yes, John.
I have tried a thumbdrive and another USB hard drive and both work fine.

The music USB hard drive also works fine on other NUCs.
Something about this USB hard drive with this NUC or this USB hard drive with ROCK.
Thank you.

I purchased another USB drive and it is working fine.
The original La Cie drive has a USB C controller on the drive side, though connected to a USB 3 port on the NUC side.
Apparently ROCK does not like USB C. I suggest that be changed going forward given the increasing penetration of USB C.
I am back on track.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.