New Intel NUC running ROCK cannot access backup share

Roon Core Machine

ROCK running on brand new Intel NUC8i7BEH

Networking Gear & Setup Details

eero based network, some TrendNET ethernet switches

Connected Audio Devices

mostly Apple and BluOS enabled NAD gear

Library Size

84,000+ tracks none of them local at present

Description of Issue

Everything works normal with the new ROCK setup on a brand new Intel NUC except that the ROCK based system cannot access any network shares to find my backup. I think I have found and followed the directions on every related post in his forum and have gotten nowhere. All the other machines on my local network (mostly Macs, iPads, and iPhones) can see the shared volumes. Every time I enter the filepath and credentials to the share I get an unexpected error message with no further information. Current shared backup folder is located on a Seagate external USB drive formatted in exFAT and connected to a Mac Mini. Been trying every remedy I can find for HOURS with no change. Help?

Hey @Edward_Brewer,

Thanks so much for getting in touch when you ran into issues switching from an old Core to a new one.

Have you seen these instructions in our help center for restoring a backup on ROCK?

Could you please let me know at what step you get stuck? If you can share one, screenshots are very helpful :nerd_face:

Thank you for the pointer on the migration doc. I had not seen that one but did follow another doc about setting up a new ROCK server.

I had not thought about trying to connect the backup volume directly to the ROCK, but just did so a few minutes ago and the restoration appears to be moving along normally.

I am still concerned about why I could not access the shared drive with the backup over my LAN, as I hope to move the drive back to its original location. I checked the settings on the NUC bios and could not see anything that was related to sharing - but I am far from adept in working with linux based boxes.

Once I confirm the restoration is OK I will turn my attention back to getting that ROCK to see the shared drive.

Thanks again for getting me part of the way there anyway.

The ROCK on the Intel NUC still cannot add a share from other machines on my local network. All devices other than the ROCK can see the share. What could I be missing? I suppose I could just keep USB drive attached to the ROCK but that was not my preference.

Did you review the faq?

Yes - I looked at that document several times and and am confident the share is setup correctly on the Mac end. All of the other devices in the LAN can see it, except for the ROCK. Is there an log that will give me more helpful information beyond the “unexpected error” dialog I get from the Roon interface when I try to add the share?

To clarify - the only thing I am trying to do at this point is setup backups on the ROCK. I do not have any significant local files to add at this point - I stream everything from Qobuz.

I would make a new backup location (not on the external drive) on the Mac, set it as a share and then see if following the instructions get it to be seen as a network location in ROCK. That way you can see if the issue is a general one or specific to that device.

Tried that too. I had a Core running on Mac Minis for several years with no backup issues before moving to the ROCK based system. The ROCK cannot seem to access shares from ANY location in my LAN. I do not understand why.

Tried the same share path in Roon that I have probably entered 25 times from another Mac on the LAN and ROCK can now connect to it. One of those things I guess. Backup has begun and appears to be proceeding normally.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.