New local albums not showing

Core Machine

sonictransporter i9

Network Details


Audio Devices


Description of Issue

I’m adding new albums to my watched folder on the internal drive in the i9. For the love of god they won’t show up. I have a roon folder in the i9 storage (8tb ssd), within that i have a folder for each letter of the alphabet. Within those is a folder for each album ([artist] - [album]). In roon only one folder watched being the “Roon” folder holding all the alphabet folders. Under this scenario it’s been a week and new album of Jim James under J is not being seen. I’ve tried forcing the folder to be rescanned but it down’t do anything and just says “watching folder in real time”… it’s not. I’ve tried removing the new version folder and then putting it bak in and nothing.

Today i tried adding the “J” folder as a watched folder and the new version is no visible. So do i need to add every folder ofthe alphabet as individual watched folders? Ideally not, what’s the issue here though?

Hi @Hugo_Sharp,

A Roon watched folder supports multiple levels of folders that are within it, so that’s not the issue.
You don’t need to add a second watched folder, in fact that’s a bad idea as watching the same folder would lead to having duplicates in Roon … so best avoided.

  • Is it just this new Jim James album that not missing from Roon?
  • Does the folder or any of tracks have special characters in them or start with a “.”?
  • Is there a small spinning blue circle toward s the top right of the right screen, if so click and let us know what it says?

Just in case Roon has imported it, but has misidentified it …

  • Check by going into the Albums screen and sort by date added, is there an “odd looking” album listed around the time you added this one?

Have you tried rebooting the Roon Core?


What does the face mean?

Does it mean you don’t like the suggestion, or you’ve tried it and it did not help?

Just spotted the topic is now marked as solved, did rebooting the core fix the issue?
Is so great news.

@Carl yep the reboot sorted it. I couldn’t find a head-slap icon…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.