New NUC install won't boot

I think that would be very helpful. To help the most people it would need to get into the KnowledgeBase. But it’s amazing how much you can pull up from the forum through the search function or even Google searches.
It doesn’t help that the demographics for the Roon User base tend to coincide with that time when memory starts to slide…

1 Like

This is interesting; I built my ROCK a few weeks ago, know nothing about Linux etc, but have built many PCs and know my way around a BIOS and installing software in general. I followed the instructions in the build document(s) and found them very detailed and very good and it all worked perfectly. BUT the instructions are not necessarily so straight forward, you start with the core (no pun intended) instruction guide and at various steps needed to go off to another guide to complete that step, then go back to the core document to continue to the next branch, and this branching off was an iterative process.

I can see that it creates confusion and uncertainty in the process, and that a single, step by step complete process in one flowing document would be very helpful to many people - During a build or installation process I often make step by step notes so that if I have to do it again, I just follow my own instruction notes stream, but when installing ROCK I did not. I wish that I had now as it would have been useful for some folks.

Yes, I was following the multiple documents, but honestly didn’t find that the hard part. It was just that, in my case, the reality was different to the instructions! It may we’ll be that if others aren’t having the same issues I just had a funky bios in my NUC from the beginning and it was just a one-off. The confusion was compounded by the fact Intel’s own troubleshooter for the error message I was getting didn’t match what actually happened in the end either.

I think I’ll put this down to a random one-off unless others report issues with the instructions.

Thanks to everyone for your help, very much appreciated.

Everything seems to be working well now, database all migrated and music files moved to internal SSD.

Next phase once I’ve tested for a few days to make sure all is good is installation in the fanless case.

But this isn’t a one-off, most likely. Roon removed support from 8th Gen Nucs for a while because people reported they could not set boot drive to Legacy.

If the Nuc is going to be ‘the standard’ install for ROCK, there should not be some installations that are standard and some that are non-standard. It shouldn’t be something up to chance or hoping that a new user can figure out the parts that are unclear.

Roon is pointing people to a purchase of an 8th Gen Nuc system on Amazon. Roon worked with Intel to get Nuc ‘just the way they wanted’ for the Nucleus, so there is a relationship (Roon & Intel) there. Its in their best interests to make the installation straight forward so we all can recommend this to new Roon users (because it is an awesome set up).
@dylan

Yes, I have a Akasa Turing fan-less case on the shelf waiting for the swap over of my NUC8I7.

I am in no hurry as the NUC is pretty silent and not in the playing areas.

1 Like

If the NUC enters the “A bootable device has not been detected” screen you have no bootable system installed.

Do this:

  1. Turn of the computer.
  2. Put a bootable USB-drive, for example a Lunix image or the ROCK image, into one USB-slot.
  3. Turn on the computer and press F10 during boot screen to enter the boot menu to be able to see bootable devices.
  4. Choose the USB-drive with the bootable image on it.
  5. Follow the instructions and install the OS on the m.2 drive.
  6. Now will the computer recognise the m.2 as a bootable device and start the OS.

Good luck!

1 Like

I find it’s too noisy to work around it in fairly close proximity, so I’ll be going fanless pretty quickly, I think.

Hmm, this is what is stated in section 5 of the ROCK installation guide

Yep, but step 2 of the Rock install guide (before the USB bootable step 5) directs you to the following page -

https://kb.roonlabs.com/ROCK:_Updating_and_Configuring_BIOS_On_Your_NUC

Where section 3 has the following steps:

Once you’ve restored your BIOS settings to the default, make the following changes:

  • Set the proper Boot Settings (you may need to click “Advanced” first) :
    • Use Legacy , not UEFI
    • Set the boot order to boot from your SSD first (you can drag the drives into the proper order if you’re using a mouse. Otherwise you can use the + and - keys
    • Disable Network Boot
    • Enable USB Boot but make sure the SSD has boot priority
    • You may need to enable the M.2 slot, depending on the BIOS version
    • Save your BIOS changes

But I had no drives showing in boot settings, only network drives. Even after updating the bios, I still had no drives here.

To further complicate things, I had nothing but network drives showing when, after this, I tried F10 on startup to get to the boot drive menu - so the USB bootable with Rock on it did not show under the F10 boot menu. To boot from the USB drive I had to go back into Bios, and check ‘boot from USB drive first’ (which isn’t anywhere in the instructions). Only then, on reboot, did the NUC find the ROCK boot on USB. With this in the machine I was able to reboot again before installing ROCK and the drives/options for all the boot drive order were all available. I re-ordered then as per the instructions then rebooted again into the ROCK install.

So after that point where I’d accidentally stumbled on enabling boot USB first, everything was as-per the instructions. Before that, it was totally random.

Regarding Intel troubleshooting, as per this wizard -

Or this document -

Given the steps I worked through (including a bios restore which didn’t work), the conclusion would have been -

Step 4: Identify errors when starting the computer.

Follow these steps if you receive the following error:
A bootable device has not been detected

Check that the drive is detected in the BIOS:
(Use a USB keyboard. A Bluetooth keyboard won’t be able to access the BIOS.)

  1. Press F2 during boot to enter BIOS Setup.
  2. On the Advanced > Boot menu, check the Boot Drive Order.
  3. Press F10 to exit BIOS Setup.

If Boot Drive Order shows No Boot Drive , the drive inside your NUC might have failed. In this case, perform a BIOS recovery (Step 5 below) to restore the drive. If you see this issue from the first boot, reconnect the drive to the board. Make sure the storage drive is inserted correctly and fully seated in the socket.”

I had tried re-seating the drive, even though through all this the m.2 and SSD were showing under PCI and SATA in bios (just not under boot drives) which did nothing. In the end it clearly wasn’t that as the drive wasn’t touched again before it worked using the method I stumbled upon above.

1 Like

A good possibility was that whomever wrote the instructions had a drive that was repurposed and thus already had an os on it.

Maybe, but I really doubt it. The folks that write up the KB articles and other information are really on their game. I would suppose that the interaction with BIOS has evolved from when the instructions were first written and/or there are variants in the BIOS that are shipped.

Many thanks for your detailed instructions. Was about to send the nuc back to Amazon. Now up and running successfully. Not as straightforward as Rock installation instructions suggested.

1 Like

No worries, glad it helped!

I’ll write up the extra steps properly when I get a moment, in case others search for it. But really, the Roon team could do with just updating the NUC/ROCK install guide.

Essentially the ROCK install guide is correct once you get to the point you can boot from the ROCK USB drive, but you have to go into BIOS first by pressing F2 on first startup and enable ‘boot from USB drive first’ before this will work. Once that’s set, reboot and go into BIOS again following the ROCK install instructions for BIOS settings. After that you should be able to install ROCK. Don’t forget to un-check ‘boot from USB drive first’ once you don’t need that any more so the NUC boots from the m.2 drive from then on.

1 Like

I have got the same problem as you had and not being a computornerd I would like you to descibe the steps you took!
Best regards
Per

Hi Per,

The steps I took are as in the second half of my post above, past that point the ROCK install guide worked OK.

Since mine’s been up and running for a few months I haven’t checked to see if the guide has been updated.

Try the above and see if you still have a problem, if not post back here and I’ll see if I can remember what I did (I’m not a computer geek either, I just kind of managed to partly accidentally stumble across the way to do it)!

Thank you James! I managed to change to legacy boot and got boot order right so now I have installed Rock but it asks for network adress?! Where di I find it and where shall I write it?

Easy one! I just had to plug in the ethernetcable! Sorry for this! It is getting late in Sweden and I have tampered along for quite a while! Now on to Codecs if I can handle that one!

I did it! Its up and running! But now I cannot access my files!? I use the adress used before but it does not work! I will check the network!

If your music files are on a NAS, use the IP address rather than the name.

Thank you, but it is on a windows computor and it does not work!