New Nucleus+ install wont play any music

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus+, Lastest software as of 17/06/2020, local music stored on external USB HDD.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Pepwave Router, TP-Link Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Amp (Also tested with Nucleus Local HDMI and laptop local output)

Description Of Issue

We are a Roon dealer and yesterday we installed a Nucleus+ onto a clients new Yacht.

The yacht currently does not have any internet so we updated all the frimware on the Nucleus+ before taking it to site. Once installed we connected the USB HDD and started the Nucleus scanning the music. It added all the music to the library but of course couldn’t “identify” or add any additional metadata as there was no internet. All of the existing embedded metadata and artwork loaded fully as expected.

We cannot get any audio to play from the Nucleus whilst its connected to the boats own network. Always getting the error “Playback was interrupted because a track failed to load” + “Too many failures. Stopping Playback”. We we’re trying to stream to Sonos AMP units and also tried enabling the Nucleus+ HDMI output and also playing directly on my laptop via the roon client software. None of these worked, alway the same error.

I had assumed that this could be because the Roon wasnt connected to the internet and could not finish its “identifying” so was preventing the playback until then. We took the Nucleus+ back off the boat and plug it into a different network that did have internet. It would then play perfectly on my laptop (didnt have any sonos AMPs conected to this network for testing). We left the Nucleus running its identify overnight and hoped that once this had completed it would then work on the boats network.

The Nucleus has been re-installed this morning and we are still getting exactly the same issue, unable to play any music.

Im guessing this highlights that the issue is with the boats network and not someting else, however not sure why the Nucleus wont play back from its internal HDMI as im assuming this doesnt even go near the network???

We dont manage the Boats network and, unfortunately, I dont have much in the way of details of the networking equipment. All I know is its a Pepwave router (i think its a Pepwave MAX HD2) and there is also atleast one TP-Link switches, could be more (i dont know the models).

Really desperately need some support with this as need to get it all working ASAP. Unfortunately im no longer onsite (only had 1 day yesterday) and the boat is a good 3 hours drive away.

Im obviously going to have to get the IT company to investigate and see if there is anything in the router/switches that is stopping the audio from streaming, but I dont know where to start pointing them or suggesting what they change to try and make it work. Im hoping they can log in remotely if I tell them what to do.

Hello @Chazman,

Thank you for reaching out! I would need to consult with QA on this issue and I have a call scheduled with them early next week to discuss. In the meantime, I am hoping that you can provide some more information here:

  1. What is the email address associated with this customer’s Nucleus? Please send this info as a private message to me (click my name -> message). Sometimes the forum is monitored by spam bots, so please don’t post the email publicly on this thread as it might get picked up.

  2. Where is the Nucleus currently located? Is it still on the Yacht or is it connected to a properly working network (with internet access)?

  3. It would be useful if you could gather any information regarding the Yacht network setup, specifically the switches models and if they are managed or un-managed. Was the behavior the same if the Nucleus was connected directly to the router bypassing the switches?

  4. Are there any firewalls active on the router or does the client have any other kind of “hardware” firewalls (SonicWall/Zytel/Security Gateway)? Are there multiple subnets in use on the Yacht?


Hi @noris @danny

Ive messaged you the email address for the clients account now.

The Nucleus is still on the Yacht, hopefully the satellite internet on the boat is going live today.

Im working on getting the model numbers of the swtiches/routers etc etc and will send ASAP

As far as im aware there is no firewalls or security gateways.

This issue was resolved. The router was giving out a bad DNS server address.

Roon requires a functioning internet connection to operate, even if you are playing local files on a local device. It doesn’t require it constantly, but it does need it occasionally for licensing purposes, metadata updates, etc…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.