New Nucleus+ - Says there was an error checking for an update

I see variations of this problem in support here. The remedies are things I’ve already tried.

  1. Hit “Reinstall” in web interface (which seems to include the notion of “update”)
  2. De-installed my Windows app and reinstalled it.

No Change. There are no firewalls, etc.I’ve been using a Mac as a Roon Core for years. Zero issues except for a USB speaker issue about 6 years ago.


So I rebooted the Windows machine that was running the Roon client after uninstalling the client. That did it. I also found the SMB1 post that led to me installing SMB1 on Windows so I could see the data store of the Nucleus.

My original core was running on a Mac, which I shut down. But on the Mac I ran into a “can’t find core” issue. I uninstalled Roon using Parallels App Uninstaller, and reinstalled Roon. It still couldn’t find the new core, even though Windows on the same network did.

Some community posts indicated I had to remove files in the hidden Library directory. These were not found by Parallels. Still didn’t work. Rebooted. Worked! SMB mount from the Mac was trivial, and am now copying 2 TB of music from the Mac to the N+. I can see the albums as they get added, which is great. No issues connecting to one of teh 6 Sonos amps I have in the house. Mobile apps connected to the new core without doing anything. Excellent.

Note, in some places you refer to the domain name of the N+ as NUCLEUS. But it needs to be NUCLEUSPLUS, as only one page i found says. You might make a documentations scan.

I’ve had no trouble for, what, 5-6 years? Looking forward to 6 more!

You can consider this closed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.