New Nucleus Set-up- Stuck on "searching for update"

I’m trying to set up my new Nucleus and I have found it on the app. It says an update is required.

When I select “update” it goes to the screen that says “one or more devices need an update” and it just sits and spins for hours.

I tried turning off the nucleus and restarting but the same problem happens.

Craig, your Nucleus is running avery old build, the current is the same as on your tablet, 1.8 B923. I read in another post that it may take awhile for the Nucleus to update itself, and to just leave it on and let it do its thing.

1 Like

Thank you. It’s still spinning after 7hrs…

You need to update the Nucleus first via its Web Administration interface…

Thank you but I tried that from both the tablet and my I-Mac. The result is the same. It is stuck on the screen that I showed. I get no option to go to the web admin page.

HIs there any way to contact ROON? I am thinking I need to return this expensive paperweight. Not having a legit tech support contact is not professional nor is it a sustainable business model. I really appreciate the support from the community but it seems that ROON is built for people with much more IT skills and interest than the typical layperson. If any ROON employee is listening please let me know how I can return this for a refund. Thank you.

The Web Administration Page is accessed via a web browser NOT the Roon client application…

I followed the instructions that you linked to. Is there an IP address? If so, please link or list

Your router should be able to tell you what IP address it has assigned to your Nucleus… Do you have enough IT knowledge to be able to do this? If not, ask, and we’ll try and walk you through it…


I do not, I’m a 65 year old retired healthcare exec whose previous audiophile experience was back in the analog days when things were much simpler, not an IT or software or network developer. I used to call IT for this stuff

OK, I’m a 73 year old retired IT person, so we should be able to work something out.

Tell me something about your setup… you seem to be using an iPad. What is providing the network in your home? Your internet provider has probably supplied a modem/router to deliver internet to your iPad. Can you say what make it is?

1 Like

I need to step away from the keyboard for 30 minutes or so - I’ll be back…

I have both and iPad and an I-mac and the I-phone that I have tried. All recognize the Nucleus and all give the same result. I have Spectrum internet. The cable modem is an AARIS 1605 which feeds a Netgear 1900 Nighthawk wireless router. This feeds the LAN in my house. The Nucleus is fed from a TP Link Gigabit switch as it is located in a different location than the router. This switch also feeds a Cambridge Audio CXN as well as a MacBook Air which currently has my I-Tunes library.

OK, so what we need to do is to use the web browser on your iMac to access the Netgear Nighthawk router and see what IP addresses it has given to your devices (your iMac, iPad, iPhone and your Nucleus).

From the Nighthawk manual, I see the following steps:

To view devices on the network:

  1. Launch a web browser from a computer or mobile device that is connected to the
    router network.
  2. Enter
    A login window opens.
  3. Enter the router admin user name and password.
    The user name is admin. The password is the one that you specified the first time
    that you logged in. The user name and password are case-sensitive.
    The BASIC Home page displays.
  4. Select Attached Devices.
    The following information is displayed:
    • Connection Type. Wired or the WiFi band for the connection.
    • Device Name. If the device name is known, it is shown here.
    • IP Address. The IP address that the router assigned to this device when it joined
    the network. This number can change if a device is disconnected and rejoins the
    • MAC Address. The unique MAC address for each device does not change. The
    MAC address is typically shown on the product label.

If you’ve never logged in to the Nighthawk before, then there may be an extra set of steps where you will set your password. Do this, and make a note of what it is for future reference…

Once you’ve found the IP address that the Nighthawk has given to your Nucleus, then enter this address into the web browser of your iMac, and you should see the Web Administration Page of the Nucleus. Then follow the steps to update the Nucleus given here.


Thank you! Found it and am reinstalling. I’ll let you know if it works.

1 Like

It should do.

What has happened here is that the Roon software has evolved, and now there is a check to ensure that the Core and the clients are all at the same build level.

This check was not present in earlier builds, so a client could be used to upgrade a Nucleus, even if the builds differed - and that is what the Help pages still show.

Unfortunately, this check has introduced a Catch-22 situation, and if the builds are different, the only way to upgrade a Nucleus is via the Web Administration Interface page.

I’ll pass this on to the Support team…

1 Like

For others finding themselves here going to http://nucleus.local should also get you to the web gui. http://nucleusplus.local for Nucleus+ iirc


Good point - this should work in most situations. I forgot about that shortcut…

Thank you all!

1 Like