New Nucleus stuck in Checking for Update mode

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus 1.6 build 416
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

hardwired to Orbi Router
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Trying to setup a new Roon Nucleus and after plugging the unit in and connecting everything, I launch the control app on an iPad Pro. Roon won’t let me connect and states the unit needs a software update. Just sits there with the message Checking for an update. I have already tried restarting and the message changed to downloading with a red exclamation point. After an hour of no progress, I restarted the unit again and back to checking for update with no progress. Since it won’t let me get to the setting menu, I cannot launch the web admin page to try a different method for updates. Any suggestions as I seem to be stuck.

Hi Richard,

Welcome to the community.

You can install Fing app (or other) on your iPad to scan your network for the Nucleus IP address. Then type the address into your browser to bring up the Nucleus Web Admin Interface.

From there, click on Reinstall button for the Operating System.

Cheers, Greg

1 Like

The web admin page is not accessed from the Nucleus Settings menu - it’s accessed by entering the IP address of the Nucleus in your web browser.

Thanks, that worked. Issue solved


Hi @Richard_Bonick,

Glad to hear things are working for you now (thanks Greg)!

Please feel free to reach out if you ever have any questions or issues.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.