New Nucleus+ won't update Core software from ver. 1.6


This seems like a familiar story here on the Roon forum… I just received my Nucleus+ and have tried setting it up. I was disappointed to discover that the Core software version (ver. 1.6 Build 416) is two releases behind. When I tried to connect to the Nucleus, it tried to update the software but failed with the message “There was an error checking for an update.” I tried resolving this problem by following the recommendation I found on the Roon Support forum, including rebooting my router, rebooting the Nucleus, updating the Nucleus OS and Server Software from the Web interface and trying to connecting to the Nucleus in several iterations. Nothing works.

Your support would be greatly appreciated.

Sorry for the trouble here, @Rick_Quisenberry!

When you did the reboot, did you use the power button or did you reboot from the Web UI? Normally rebooting from the Web UI works best if you haven’t tried that yet.

Assuming there’s still no change after that, would you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

Roon 1.4 is a very old Nucleus stock. Maybe still something broken for these old models getting updates still. @dylan danny seemed to think this was fixed a work or so back but that was from 1.6 updates … 1.4 is really old.

Thanks for the response Dylan:

I have tried rebooting the Nucleus from both the web admin. page and the physical switch with the same results. My shared Dropbox link for my Roon Server log files is here: Dropbox - Temp Share - Simplify your life

Sorry - I miss spoke… The version on my Nucleus is 1.6 (Build 416) - not ver. 1.4.

My bad.

In that case might have to be @Danny to the rescue

Your logs show you are running 1.8. It’s the first line in the latest log:

07/27 00:38:16 Info: Starting RoonServer v1.8 (build 806) stable on linuxx64

Do you see otherwise?

Thanks Danny.

Sorry - I’m new to this Roon server environment. I posted the log files from my current NAS Roon Server. I actually followed the instructions this time and went out to the Nucleus+ and retrieved the log files. They are here:

Your DNS settings are bad. The server can not resolve any host names.

Are you using DHCP or static IP?

1 Like

Thanks so much Danny. I changed the DNS setting and that fixed the problem.

Take good care


it really does … always a networking issue :joy:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.