New Orbi network getting Network Error: Please check your internet connection

Core Machine (Operating system/System info/Roon build number)

Roon Rock on NUC / Version 1.0 (build 227) / Version 1.7 (build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi RBR850 / Wired to Satellite

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB connection to PS Audio NuWave DAC

Description Of Issue

I recently moved and set up in an Orbi mesh network at the new house. I have the ROCK wired to a satellite on the Orbi system. The NUC connects to the network, gets an IP. I can connect to the Roon server via IP address and see the System Status page and can reboot the server. But, on two Macs and two iPads, I get the error message Network Error: Please check your internet connection when logging into the Roon app. All devices are connected to the same wifi network via DHCP.

Hi @Steven_Marks,

Since experiencing this issue have you tried rebooting the ROCK Core?

In your Orbi’s settings can you try setting it to use Google DNS or Cloudflare DNS?

Hey Dylan,

Thanks for the quick response. The issue is solved. But figured I would put the answer here in case it helps someone else.

I did try rebooting the ROCK. Didn’t work.

The Orbi is connected to AT&T, which requires their DNS. The Orbi is set to AP mode.

The problem was I was set to Static IP and the Gateway address was for the old network and the DNS was set to Google (

I changed the Gateway to the AT&T router’s address and rebooted the Core, but it still didn’t work. I went back in and set the Core to DHCP for IP address, rebooted the Core and now it is working. DHCP set the DNS to the AT&T router address instead of Google, so you were right on it being a DHCP issue.

Thanks again,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.