New Pi and tracks skipping

Just got the Pi set up yesterday , it was a promising start.
However today when playing albums , the playback started skipping tracks. In the middle of a track it would just jump, sometimes to the new track, sometimes a few tracks.

Set up is Roon to Pi to Burson 3XR headphone amp via USB

On wifi?

How strong is the signal strength / link speed between the Pi and your wifi router?

Yes its on wifi, it has to be as its upstairs
When the signal strength was tested yesterday it was good.
I have also just had the same thing happen when using my lap top instead of the Pi. Skipped about 4 tracks.

So then just used the Tidal app from the lap top …flawless so far but only about 40 minutes listening

This certainly sounds like wifi issues. What model pi?

You can try down sampling in Roon to 16/44.1 to reduce demand on the network. That may give you an idea if it is network. Or move to a location you can use a wire for a bit.

What is your wireless network set-up? If you’ve got some kind of mesh system can you move one of the remotes close enough to the pi to wire the pi into the pod? The wifi on any pi isn’t great. Better on a 4 but still not great. Also depends on what kind of case you’re using. A lot of cases can reduce signal strength especially the metal passive ones.

1 Like

Its a Pi4 . It was built for Roon and I got it off ebay . It does have the metal case yes.
Unfortunately I cant use from a position where I can wire it
Its just a BT router but its only about 6 meters away from the Pi. Its a new build house and the Wifi has been really good so far with no issues.
It may even be a temporary Roon issue as like I say I got the same skipping of tracks from my lap top too. Also Tidal app has worked with no issues so far when used on the same laptop

I will continue to use the Pi and the lap top see if it keeps happening.

Unfortunately you just cannot compare performance of Tidal or Qobuz outside of Roon standalone to the usage inside Roon.

What maybe good enough wifi signal for standalone may very well not be enough for inside of Roon.
Roon can be very bandwidth intensive.

As @ipeverywhere suggested try a lower resolution like Redbook 16/44 and see if any better.

Is it possible to use a USB WiFi dongle on the Pi? That might have better reception.

1 Like

If it’s in a metal case you might want to try an external WiFi dongle as it blocks some of the signal.

1 Like

Or Just use the Tidal app. Its more convenient for me than changing resolution.
Thanks for the explanation though , it now makes sense to me.
I dont really want to go through all of the dongle rabbit hole if am honest.

I am hoping it was a Roon thing as for the last 3 hours the Pi has been flawless…wish i had not said that :wink:

1 Like

I dont really want to go down this route.

You might need to do this though to get higher throughput.
Another option is to take the Pi out of the case to do further testing, this should give you improved performance so you can see how well it works.

I had some nice metal cases, only really worked well on Ethernet


I just want a simple solution. If it needs case removal etc then its not for me. I will get something that just works out of the box.

I am hoping it was just a blip earlier as is now 4 hours or so with flawless streaming. It sounds good too

1 Like

Ok Steve you have to go with what works for you. Good luck with your choice

1 Like

Ok I spoke to soon…skipping tracks again.
I will have a look at some wifi dongles, but its a shame as worked for 4 hours or so.

Does the dongle just go in one of the USB ports in the Pi? Any ideas on what type may work

Also is this just something I have to accept with a wireless set up? So if it happens every 3 or 4 hours or so I can probably just live with it

Steve Roon do not recommend WiFi for any devices and it may work at 16/44 and below but it is tougher as you get to higher resolution.

I would say a bare case would be a good start for testing and should only take a couple of minutes to take apart and use as a bare case to see if the WiFi is strong enough

Are you using Rooopie for the Pi?

Hi Michael yes I know they do not recommend wifi devices but when I asked for advice on this forum I made it clear that it had to be wireless as its in a different room.
That is not a pop at you or anyone else who helped me as I am grateful as I am clueless about this stuff.

Yes its Rooopie , it was already set up.

I will switch to my lap top again and if this works the Pi will be sent back.

The last 30 minutes or so have seen a lot of dropouts , thats no good at all. Its a real shame as I think it sounds great.

Tidal media is loading slowly. This may indicate a connectivity or network issue.

This is a message I am getting , there is another one too, but did not quite catch it

WiFi can work well within certain parameters and a good clean signal is one of the requirements, its just not a recommended solution with Roon. Remember that WiFi is not Duplex so other traffic on the WiFi network can have much more of an impact than with Ethernet.

I have never used one of these Dongle with Rooopie but I did find an external BT dongle for my RooNuimo the other day and that worked a treat to get through the case.

Maybe @spockfish can help point you in the direction of a working USB WiFi dongle maybe even with an antenna

Thanks Michael
I understand wifi traffic but I am home alone doing very little else
So my lap top has been the Core for last 6 weeks . This has been connected by USB to the Headphone amp. Not a single issue.
The Core ie the laptop has been wireless and has worked flawlessly.
Now the Nuclues is back I have set this as the Core again. This is hard wired to the Network switch…but its now I get the problems…makes no sense to me.

Just to add lap top having the same issues now.

So when lap top is the Core …a wireless core at that I have no issues for 6 weeks.

How easy is it to swap cores every time I use my Headphones? Is this a viable option?

Steve I would not generally recommend logging in and out of two cores in the same house, though not sure if it will cause any issues. If you can get a good signal then that will help, but if you play local music does that improve the problem as you are adding Tidal to the issue here as well.

Do you have a local library to test with?

1 Like