New Pi4b on 2.535 Unable to enable wifi

I will do so, thanks Harry.

Cheers John.

Up and running again, thanks again Harry.
Never happened before using 3 RPI’s
I have probably been impatient :flushed:

Cheers John.

Just spotted that my Pi-hole was blocking requests to “” from the Ropieee last night. Do those requests play a part in enabling the WiFi network?

I would disable this blocking and try again, but an embarrassing mistake earlier today resulted in my snapping the SD card in half, so I have to wait until a new one is delivered.

Is this for resolving the county code? Can you prompt the user, default to US, or use a free IP database?

Yep, that was it. New install with the api whitelisted successfully connected to WIFI.

This issue almost made me drill a hole to pull a cable into my bedroom.
@spockfish maybe you want to avoid this commonly blocked URLs.

I am fairly new to the Raspberry/Ropieee community and just finished my first install today.
I have a Raspberry Pi 4 Model B Rev 1.2 with the official 7 inch touchscreen, connected to an external DAC via USB.
I was able to setup everything and get the Roon endpoint going and I see it on my Roon app and on the computer I use as the Roon core, and I can see the artwork and data on the touchscreen with no problem.
I’m having trouble connecting via Wifi. I used the Network tab to turn it on, it found the network, I typed the password, rebooted and once I unplug the ethernet cable, I get no connection at all. If I do a reboot, It just idles saying that there is no internet connection, but as soon as I plug back the ethernet cable, everything loads up and it works.
I’ve turned it on and off a bunch of times.
I’m pretty sure its not the wifi hardware because I’ve booted up Raspberry OS on another SD card before and Wifi worked fine.
What should I try?

This is my feedback ID:


Hi @DiegoRST,

There’s an ’ in your ESSID that is causing problems.
I’m going to look into this, but for now if you want to use WiFi I suggest you change your ESSID and remove the character (’).


That worked! Thanks again.