New ROCK NUC with internal storage slow loading of tracks

Hi Guys,

I have recently built a an I7 NUC with a 500Gb SSD/8Gb RAM and loaded music onto the SSD.

It seems to play 44/16 FLAC OK, but has trouble with 96/24,etc - I get the message “An audio file is loading slowly”. “This may indicate a performance or hardware problem”.

I have tried connecting to the same router as the DAC (PS Audio DS DAC), but no difference, I have tried rebooting the NUC and the Routers and switches in my network, which are all of great quality.

Any ideas?



I have found this is normally down to networking issues in my setup. I recently was using one of pi endpoints using wireless and got this playing anything. I changed the adaptor to a newer one and it’s now fine.

Can you connect the core direct to your DAC vis usb and miss out the network and see if you get the same. This might help identify if it’s the nuc or network.

A little more detail about your network would be good. Is it wired or is it wireless. How is everything connected?
Also you only talk about one SSD drive in your NUC. If you’re using ROCK then you cannot store music on the SSD that the operating system is stored on. You need a second drive installed in the NUC for the music library.


I tried the USB - same problem, so it is unlikely to be the network?

Sorry I have a 128Gb ssd, with ROCK installed, then a data drive of 500Gb.

My network is a Netgear GS 7481 managed switch and 2 Linksys DD-WRT (build 28788) routers running seperate networks, plus s few wifi access points.

I’m running the NUC hard wired on my main network. The second network is business only. I have download speeds of approx. 100Gbps.

I have most of my music on the storage 500Gb SSD on the NUC, some is stored on a NAS on the same network.

The problem appears to be mostly with higher resolution files - Redbook seem largely OK?

Hope this helps?



Sorry, forgot to mention - I had a Mac Mini as a Roon endpoint on exactly the same connection, which worked perfectly for years. It used the NAS and its own SSD for storage in a similar manner.


Hey @mal_fl — Thanks for reaching out!

Just to confirm, this is media that is stored directly on the NUC that is always unable to play, even to devices connected via USB? Or is the media that is unable to play stored on the NAS?

Can you share a screenshot of your settings in Settings > Storage?


Thanks Dylan


I have music stored on both the NAS and the SSD of the NUC. I believe the music is playing from the NUC. In this case.

It is mainly with HD files - they take ages to start, then stop/start and skip to the next track. Red book tracks play largely ok, however they seem a little slow to load. and occasionally skip or stop/start.

Screen shot:


Hi Guys,

Just an update - I reconnected my Mac Mini and surprise, I had exactly the same problems - not the NUC, I suspected.

I went to work on my network, but couldn’t find ant specific issues, so I went back to basics, rebooted everything in sequential order from the Modern, switch routers, wifi (although connected via ethernet) and lo and behold a light sone upon my NUC and all is good in the world!

Amazing that a coincidence (a new NUC) can mask a network issue.

Interestingly, I read an article from John Darko (below), so I am going to try wifi, vs ethernet.

Thanks for your help.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.