New ROCK on NUC causes “Unexpected Error Communicating with Audio Device”

Core Machine (Operating system/System info/Roon build number)
Intel NUC5i5MYHE - i5-5300U Dual Core 2.3GHz - 4Gbs RAM/Boot SSD 120Gb/Music SSD 500Gb

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Apple Extreme/ROCK on ethernet attached - control/output wi-fi 5Ghz

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Wi-fi Pi4 Ropieee -> USB -> Mojo DAC
Wi-fi MacBook -> USB -> Mojo DAC

Description Of Issue
Hi - I’ve just updated to a ROCK Core installation (NUC 5i5/4GB RAM/120GB SSD+500Gb SSD) to keep things nice a separate and take the load away from the MacBook I listen on and use all day whilst listening, and it went fine (well not exactly turnkey is it! :blush:). Anyway after lots of file moving, backup restoring and setup stuff I sat down to listen on my MacBook and when I press play the error “Unexpected Error Communicating with Audio Device” comes up.

I’ve isolated it to the convolution filter I use for my headphones, turn that off and all is well? I thought the separate ROCK server would give more oomph not less and according to specs it ought to at least compare with the early 2014 MacBook Air? The ROCK is connected ethernet to the router directly, MacBook is wireless 5Ghz - I’m just about about to try the Pi4 endpoint I also have a little speaker DSP on next to see if that has a problem too, but I thought I would just see if anyone had encountered this before? I have found similar issues in search but not the same situation. My network never has issues and is always fast, but I presume the DSP was being done on the actual MacBook before so local to the Mojo and headphones attached? Do I need to dial in some delay somewhere?

*Update: Pi4 works lovely, speaker distance and gain not a problem - removing the Mojo and enabling basic system device output for the MacBook and using this with same DSP filter also not a problem? Very weird - looks like Roon ROCK don’t like me Mojo all of a sudden?

*Update 2: I’ve completely removed all trace of Roon on my MacBook (it had been core/control/output and then Server/Control/ Output so there was loads of bits left over) reinstalled Roon and no change. I have found that I can add the Audeze filters (just to check its not a overload issue) plus upsampling and whatever with no problems - its only the HD600 convolution files that seem to stop everything dead? Worked fine before ROCK - but that’s IT isn’t it, cleverly unrelated coincidences can take you off on many a blind alley! :blush:

Further update - I have checked out the file accessed by the convolution filter (in case it should be on the ROCK server or something) and discovered when I was moving it that Roon can no longer read it and that’s the actual problem - Unreadable Zip File is the error message - which I can’t find listed anywhere on here? It seems since moving the core to the NUC under ROCK something has changed and Roon no longer likes my Mac zip files? Anyone had these problems or is it just me?


Solved Yay! :grinning:

It was the zip file! I downloaded YemuZip from the app store as it claimed to strip any Mac nonsense out of the zips it created so they opened in Windows (I didn’t think this was an issue anymore but thought for £4.99 I’d give it a try) and lo and behold Roon now likes my convolution filter again!

Obviously when I was using the MacBook as control and core and output there was not problem, as the core was a Mac app running on a Mac, but now the MacBook is just a remote control, the ROCK core is what was looking for the zip file and not liking a Mac version at all.

I do think this ought to be mentioned in the convolution docs though, or maybe somewhere specific to ROCK perhaps, as I couldn’t find any mention anywhere of Mac zip incompatibilities. It’s only the years spent messing with IT meant that helped me out, something stuck in my mind about zips and their incompatibility across platforms otherwise I would have been lost for a solution! :blush:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.