New Roon Nucleus+ Doesn't Get Past Firmware Update

Roon Core Machine

Roon Nucleus+ Rev B 2TB

Networking Gear & Setup Details

Fios Gateway Router
Eero Pro 6
Eero Pro
Eero Beacon

Connected Audio Devices

LG TV (WiFi)
Sonos Amps (WiFi)
Sonos Ports (WiFi)
NAS (ethernet to Eeros Pro 6 at head end)

Number of Tracks in Library

22,000 tracks
But this does not matter since the issue is simply connecting the Nuceleus+.

Description of Issue

I just got and installed a Roon Nucleus+.
When I connect to it using Roon remote on my IPhone or MacBook Pro, the following happens:

Software Update needed…
Checking for an update…
And the spinning wheel next to the Nucleus+ keeps spinning.

The Nucleus+ is connected via ethernet to an Eero Pro 6.

To troubleshoot I have:

Cycled the power
Connected to the web interface and rebooted.
Connected to the web interface and reinstalled the operating system and gotten “success” messages.
Changed location of the Nucleus+ from my media center Eero to the head end Eero in the basement (disconnected the NAS)
Connected Nucleus+ directly to FIOS gateway router and used FIOS wifi to connect to Nucleus via MacBook Pro. Same result w/ Nucleus+ timing out attempting to update software.

It seems that the device may be having issues connecting back to the Roon “mothership” to check for and grab the firmware update?

Please advise.

Hi Jordan,

Did you get this issue resolved?

There were a few other users that posted a similar issue here on the community. Apparently, Roon did some backend work and it resolved the issue for them.

Could you try and Reinstall the Operating System again and see if it works now?

Hi Greg,

Thank you for gettting in touch.

Yes, Rebeka from Roon contacted me via another thread and provided some instructions after something was fixed at the Roon mothership. I followed the instructions and am all set.

Now I am only having issues adding music to the Nucleus+ internal storage. I opened a separate topic on that though.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.