New Router causes audio device to disappear


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I’m attempting to upgrade my router to one of the latest ASUS models but a coupe, of end points have disappeared.

Putting the old one back into use restores them, so it must be a router issue. Both ‘missing’ endpoints are Ethernet based rather than Wi-Fi. Ones a SoTM and the other’s a Raspberry Pie. Oddly the other Pie works find.

So it’s either a Ethernet driver issue on the end points or a router setting that needs attention.

Any ideas?

Were either of the missing devices assigned a fixed IP address when connected to your old router? If so this could cause problems with the new one.

On your Asus Router under LAN - IPTV settings see if Multicast Routing is enabled and try enabling/disabling IGMP Snooping as well.

1 Like

Follow the above post and disable AI everything, QoS, AI protection.

1 Like

Thanks all.

I finally found the time to spend with the router and settings suggested all worked. Nearly full service returned. One Endpoint still not working, but at least its appearing in the Roon list.

After you change any router settings, wait for it to be applied, then the whole network of devices including phones and endpoints need to be rebooted.

Agreed, and all the smart switches in between too

I spoke too soon. On reboot one endpoint, a pi running roopieee, isn’t visible to roon, even though I can access it and the ropieee interface from it’s IP address.

Funnily enough my wife’s lappy can’t see the network either.

Have you made any changes to the firewall settings on the router? If not, it might be worth turning it off to see if it makes a difference.

I’ve not changed anything to my knowledge as I took the settings from the old router to the new. interestingly I’ve just noticed my apple TV isn’t recognised by roon either, again though it work fine by itself.

It can’t be the ethernet drivers can it?

This isn’t my area of expertise, so wait for someone else to chime in, but it could well be that a setting from the old router is causing problems with the new one. One solution would be to factory restore the new router and start over, but that would be a bit of a pain.

Actually, that’s not a bad idea. finding the right moment though is a problem. the family seem to need 24/365 access to the web.

Yeah, I save the same problem with our kids. Whenever I have to take the router offline they mope around as if the world had come to an end. Just tell them it’s for their benefit - if you don’t fix it now, it might break when you’re not there, then what would they do? :wink:

1 Like

Please confirm you did not restore a backup of old router setting to a new router.

This is forbidden, not even across different versions of firmwares of the same router.

Please list the settings of Multicast Routing, Jumbo Frame, IGMP Snooping, AP Isolated, AIProtection, QoS, Firewall, and everything that begins with AI.

1 Like

Odd that. The review I read said the opposite.

But having reset the router as suggested, all devices are now visible based on the factory defaults.

1 Like

Excellent :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.