New router - No ROCK

This has got to be a simple solution. I had to replace my network router and the new one uses a different private addressing scheme. The old one was and the new one is I was able to get all of my other devices to use the new scheme, but just re-booting the ROCK did not work.

Do i need to take the ROCK offline and hook it up to a monitor and re-boot it that way. Sorry if this seems a bit fuzzy, but the ROCK has been a “rock” the last few years living in my rack with no monitor, so I don’t remember the procedure t set it up.

Thanks for any help.


Did you set ROCK up with a fixed IP?

Hi Henry,

I honestly don’t remember, but if I did then that would make sense it is not re-connecting with DHCP. I suspect I did not use a static IP, but not entirely sure.

On my computers, I had to renew the dhcp leases in order to get on the new local network and I suspect that I have to do the same for the ROCK but do not know the linux commands to accomplish this.


So I checked the BIOS but that doesn’t set the network setting so it must be when I originally set up the ROCK. Do I now have to re-do the entire install?

Or is there someway to just re-new the lease?


You could do it but honestly the easiest way is to change the lan IP address of your new router to and let your other devices acquire new leases.

I did this recently. Got that sinking feeling when I realised what I’d done. A clean install fixed it.

if you set a bad static ip, you can introduce a second usb ethernet adapter which will default to DHCP.

Sorry to be offline the last couple of days, but my router died and the ones I bought would not work with Xfinity. So the tech showed up with an Xfinity router which happens to use my old addressing scheme and voila - Roon ROCK is back

thanks for all the suggestions.