New Setup and No Displays Showing

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RaspPi NanoSound One (HiFi Berry on RasPi)

Description Of Issue

I just set things up. I am hearing music streaming from Qobuz on my speakers. I go to the Displays tab and my Chromecast is not displayed. I am also using Chrome to go to the URL listed, and I see the Roon logo, but it is not being listed on the Displays page in settings. I have rebooted the Chromecast and that didn’t help.

Hello @anon7295733, and welcome to the community! Our article on using Chromecast as a display is available here. The important part is that you select an endpoint to play to then click the button shown below.


If you made it to the Roon logo, go ahead and play a track. When you see that logo that means your Chromecast is in standby waiting for you to play something. Give it a try and let me know if that helps.

Hello and thanks for the reply.

Let me correct a few things. I have seen the document. I never see the cast icon. The Chromecast IS NOT displaying anything. The web browser on my computer is displaying the room icon. Neither the Chromecast or my web browser ever show up as a detected display device in roon.

Hello @anon7295733, could you please send me a screenshot of Settings>Displays?

Hello @anon7295733, and thanks for the screenshot! Could you check if the Chromecast and your core are on the same subnet? Can you see the Chromecast from another device? Lastly, to clarify, your core is connected via Ethernet, right?

Everything is on wired Ethernet. I can stream to my Chromecast from my Android phone and my iPhone. Everything in my house is on the same subnet.

Hello @anon7295733, do you see the device if you temporarily disable your firewall/antivirus/VPN?

No. That has no effect.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.