New software cannot connect to core

Roon Core Machine

Core: Nucleus+
Remote: MacOS system, Monterey (was High Sierra ver.13)

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hello, I am trying to contact support as I must have done something wrong most of the day in making contact.

This morning I launched Roon and I received a message that the remotes (iPad, iPad mini, iMac) had “incompatible versions” to the core (Nucleus+). Everything worked fine yesterday but today I found out the my MacOS system, High Sierra ver.13 apparently is longer capably with the Room 2.0 build 1128.

So I upgraded my iMac to OS Monterey, which was loaded successfully. Still I received the same incompatibility message. Two members of the community said to download new Roon software from the Roonlabs site, which did following the instructions moving the download into my iMac Applications.

I restarted the iMac in case that may have been required. I now get the “Choose your Core” screen asking to either select “Find your Roon Core” or “Setup core on this Mac”. I selected “Find your Roon Core” which simply gives me the ball of death which continues to search finding nothing.

I have no idea what needs to be done from here. I would appreciate someone walking me. through what needs to be done. Please understand that I am not a computer guy, so some level of handholding will be required.

Thank you

Hello, I have a similar problem. About two days after updating to Roon 2.0, it ceased connecting to my music server (SonicTransporter STi5 by Small Green Computer). I’ve rebooted the server and my streamer (opticalRendu by Sonore) a few times and reinstalled their common operating system. They appear on my network as normal. Next I deleted and reinstalled Roon 2.0, first rebooting my computer (MacBookPro running OS 12.2.1) to avoid caching. All I get is the message Find Your Roon Core. My core is never found and Roon won’t set up a Roon Core on my Mac. I’ve no network problems that I’m aware of. Roon 2.0 did operate well for a day or two before this failure. Thanks. Peter

My Nucleus Rev B keeps losing it’s connection. When that happens, I turn it off and unplug the power and ethernet cable. After a few minutes, I plug the ethernet back in, then the power cable, then turn on the Nucleus. After boot up, it usually connects. I don’t know that unplugging the cables does anything, but why not? I never had this before Roon 2.0.

1 Like

Further to my post on this thread of 25 minutes ago. I did get Roon working by re-installing Roon Server on my music server. The music is distorting badly now, but at least I can fiddle around with the settings :wink:

I am running the Roon software on my Nucleus+ and using remotes such as iPads and on my iMac. When trying to launch the app on my iMac today it Said “Imcompatable Version” as the reason it could not connect to the core (which says it has the latest software version) However the iMac has the version 1.6 build 884, not the 2.0 version, so I understand the issue.

However I cannot see the way to update the iMac to the latest. It gave me the option to change my core to the iMac, but is not what I want to do given the Nucleus+.

How do I do this?

Your Mac needs MacOS Catalina or later to update to 2.0. What MacOS are you using?

Please confirm macOS version running on the iMac. For Roon 2.0 you need Catalina or newer.

Also see these help articles…

Downloads available here…

Nowhere can I find how to update the iPad or iMac (version 1.8 build 884) to the newest version.

How do I do this?

Download and install Roon for your platforms (MacOS, iOS):

Peter, thanks for the reply.

Not sure what Roon is doing here, seems like the problem is growing with other users. Sadly I bought into Roon thinking I could just listen to music, not explore software and computers.

Ive tried everything I know on this, just waiting for Technical support.

Thanks again

As far as the iPad is concerned, download the Roon app from the App Store.

Once the iPad is updated, doesn’t Settings==>About give you the option to update the Roon on the iMac?

I’ve have been doing this with my Nucleus (revA) for the past year. Sometimes works for a month,other times several times a day. Glad i didnt get the lifetime membership.

Thanks for response. I tried updating the software on both my iPad and iPad mini as suggested, still the same thing, cannot find the core.

Hmm, I thought the problem was that you couldn’t update your Mac, not that you couldn’t find the Nucleus.

Are you saying that with v2.0 on the Nucleus and V2.0 on your iPad, that your iPad can’t find the Core?

Isn’t that different from your original post? Dunno.

Also, are you sure V2.0 is running on the Nucleus? What does the Web GUI indicate?

No it’s still the same issue. I updated the software as suggested but as I said the first screen that now appears on all of my remotes iMac, iPad, and iPad mini asks “Choose your Roon Core” with the options “Find my Roon Core (Nucleus, Rock, etc.)” or “Set up a Roon Core on this Mac”.

Once I select “Find my Roon Core…)” it searches endlessly without finding the Core. Network is working fine, rebooting of all items including the Nucleus+ has no effect. Whether the Nucleus+ has the 2.0 version of the software cannot be verified as I cannot get into the Nucleus as I cannot get the screen to find it. I have to assume as the Nucleus is connected to my network and always on that it took the automatic update.

I cannot bypass this screen, so whether the original screen I saw saying “Incompatible Versions between remotes and Core” is still there is unknown.

Let’s make sure your Nucleus is the way you think it is. Hook a monitor to your Nucleus (I think a TV with an HDMI input will also work, but I haven’t tried that) and note the IP address that is displayed when you boot the Nucleus.

Enter that address into a browser. You will get something similar to this display from my ROCK -

Here is a screen print of the original screen I received when this started. It shows the Nucleus+ has the 2.0 build 1128 software.

This screenshot shows, as @xxx pointed out earlier, that you need both devices plus iOS devices on the same version of Roon.

Since you updated the iMac OS, you should be able to run Roon 2.0 on all devices now. Help guides were posted earlier.

However, it’s not clear if you have or haven’t done this; is this screenshot still relevant to your problem? Please confirm.

Likewise, please navigate to http://nucleusplus.local and share a screenshot. If this doesn’t work, use the IP address using the method @xxx describes.

If your Nucleus is up and running V2.0 and your iPad is running V2.0, but your iPad can’t find the Nucleus, then that’s the first problem to address, never mind the Mac.

If your Nucleus is up and running V2.0 and your iPad is running V2.0 and you can connect to Nucleus, then what does Settings==>About show for the Mac?

I have verified that the software versions on both my iPad and iPad mini are the current version of Roon, both indicate 2.0.01127. I am trying to locate the Roon version on my iMac but I am having difficulty, as when I click on the Roon icon it bring up the Select Roon Core screen appears. I tried navigating to http://nucleusplus.local but that does not open. The IP address method is what, simply typing the IP address into my browser, as if looking for a website?