New (was back in 2021) iFi Zen Stream device

I connect the ZS to the Topping D90 DAC, and I usually play Tidal, and there is no problem at all with firmware 2.30.7. After I updated the firmware 2.31.7 (not beta) today, however, once I play songs with MQA 96kHz or above, the song cannot be played smoothly, and the display on the DAC keeps shuffling between 48kHz and 96kHz. And once I turned the dial wheel to Roon only mode, only COAX works, and there is no way to change the output to USB. Hope it can be fixed soon.

Paul it’s a bargain, and the early problems are gone.
For Roon and HQP (which I think you use) it’s a killer device at it’s price point.

Sorry you have had to read so many of my word’s :face_with_hand_over_mouth::grin:

Bill I have Pi solutions as well (5 in the house) and they are great. Not a patch on the Stream though for SQ and besides some of the pain from testing thing’s for this thread I have had almost no problem in the 11 months with the Stream running Roon (let’s not talk about some of the other stuff).

For anyone happy with a Pi stick with it it’s great.
Spockfish does Amazing work on Ropieee and I also like the HifiBerry OS device’s I have with hat’s.
RooExtend is also coming along nicely and I have two of those as well. Finally I have a DietPi which has been running for almost 4 years.

I asked the question of Roon about recertification and was told that Roon does not check or recertify future firmware’s. This was in relation to Cambridge Audio that broke it on the Evo range

It is disappointing to see them not fixing this obvious bug though.

Yes another person had this issue in the beta as well.

Hi, Michael, I have found the workaround.

Not only DSD cannot be played, but also volume is very low. So, I managed volume options like this.

Even if you want “None” in Volume Options, Mixed Type, you should first select “software”, and set default startup volume and max volume to 100, and save. Again, you should select “hardware” and do the same thing. And, finally, you select “none” in volume options, mixed type, and save. Now, I can play both PCM and DSD at an appropriate (not unusually low) volume level!

Anyway, this 2.31.7 is not a stable firmware at all.



1 Like

Hey guys, the USB mode is working after all!

  1. Set the dial on the back to mode 2.
  2. Open Roon, go to Audio settings, make sure the ZS is enabled. It’ll show S/PDIF.
  3. Click on the “DEVICE INFO” that appears at the top
  4. In the pop-up, select “Configure device”
  5. A separate browser window will open up, allowing you to select output, volume and DSD settings. Change output to your DAC instead of S/PDIF, and voila!

Note that when doing this it also fixes the DSD options bug and the channel options disappear—everything is working perfectly now!

:relaxed:

5 Likes

Thanks for sharing that, it might helps others with the issue.

1 Like

Had you already figured it out? I found out from a user on Head-Fi. I wasn’t even aware of that device info tab. There’s even a link in that browser window that allows you to update the firmware!

I have not seen those on my system at all.
I was looking in Settings->Audio but I never saw a configure device, so I was going to the web page to do this.
I will have a look tonight and see if it is magically there now.

1 Like

I did it right from Roon on my phone. Never caught it before, although it’s been there all along, for Roon Ready devices, if you click on that “device info” at the top of the audio settings for the ZS. Let me know if you get it to work. Have a great day!

1 Like

It does work and sound quality seems slightly better than AIO.

1 Like

I agree!

Now if I could only resolve the clipping I’m getting with DSD upscaling. If you enable headphone management but set the cutoff to zero, it maintains a bit perfect signal but the little signal star turns red when it clips. Doesn’t happen if I turn upsampling off. But I think this is a Roon issue, not a ZS one.

Anyway, glad one problem is solved…

No worries. I bet you didn’t think this thread would be 1800+ posts in and still going.
Thanks for moderating it.

1 Like

:blush: :see_no_evil:
It was started to help me make the decision as to whether or not to buy one or not.
Good news now, plenty of help for the new community or Stream users :+1:

2 Likes

I’m not sure if this is old news, but the latest firmware also includes an auto firmware update tab that apparently allows the device to automatically install new firmwares, beta or otherwise, in the background—even when you’re device is set to mode 2. So this may obviate having to switch back and forth…

Also Michael, I was unaware that you were the OP for this thread. My sincere gratitude to you :pray:

5 Likes

Up and running with the new FW, but I’m not seeing the “configure device” option in Roon as shown in Steven’s post above. The Zen shows as Roon ready, and I can switch to USB in the iFi app if Im in AIO mode. If I turn the knob to Roon Exclusive (position 2), Roon shows as still playing, but there is no music and the iFi app won’t connect. Thoughts? Thanks all for flagging this update.

Do you see it when you click on the “device info” under Roon ready for the ZS? I didn’t realize that you could click that area.

1 Like

That worked for me. Thank you for the tip.

1 Like

Ah - thanks Marco. I did that and the IFi config page opened in a browser. It looked just like what I see in the iFi app, and my USB output was sellected. I’ll try the Roon Exclusive mode again a bit a later - I need to get some work done.

2 Likes