Newbie here some issues I cant find in FAQ [Sample Rate Conversion stuck on Disabled]

Using latest version (downloaded 3 days ago) I have an HP, I5 cpu, 12 gigs of ram. I am am also using streaming to microRendu with a Vinnie Rossi DHT dac. Two basic questions I cant seem to upsample to356 kHz for pcm. When Igo to the audio setupit does not allow me to upsample, why

Also I know that Roon requires small print format to load all albums etc but in playback mode I would like bigger print so I can read screen from 8-10 feet. Is there a way to do this?

Audio Setup lets you set maximum sample rates, in order to prevent Roon from trying to play sample rates your DAC doesn’t support.

Is that where you’re looking, or are you looking in the DSP screen? More info on DSP here.

Not yet, no.

In the dsp screen I cannot set upsample to enable.

Can you post a screenshot of the setting @ted_betley?

The Sample Rate Conversion is set to “Max PCM rate” meaning Roon will upsample to the highest PCM rate your DAC can receive. What does your DAC say it is getting ?

My dac is getting no upsampling. Cd shows as 44 kHz.

The Sample Rate Conversion tool says “Disabled” at the top of the screen. Toggle it to “Enabled”. The DSP engine as a whole and each tool/filter have separate toggles.

That is my problem Roon wont let me toggle it. It is stuck on disable.

Firstly try power cycling the Core (turning it off, waiting 10s and turning it on again) and see if that unsticks the toggle, it could just be that the software has gotten itself into a bad state.

If power cycling the Core doesn’t fix it then could you post:

  • a screenshot of your Roon device settings tabs relating to the microRendu; and

  • a copy/paste of the device information for your DAC from the microRendu SonicOrbiter web app.

Those will help narrow down if there is a particular issue here with the hardware reporting capabilities to Roon and the mR.

If power cycling doesn’t fix it then we will flag Mike back into the thread and I know he will be keen to track down what is going wrong for you here. I’ve shifted this thread into Support for increased attention until we can get you working.

Edit: I see you mentioned that “Enable” was stuck in your post above, apologies for not spotting that earlier.

Let me say that although I am having minor issues I believe that Roon is very very good sonically. I come from HQP which I have abandoned because of network connectivity issues. You guys at Roon have it together.

Thanks Ted,

Those Roon screens look fine to me.

The SonicOrbiter screen that might help Support, is in Apps/DAC Diagnostics. Mine looks like this:

Let’s drop a flag for @mike to check back in.

1 Like

Hi @ted_betley ---- Thank you for the continued feedback and more importantly the patience while our team has been trying to understand what could be causing this behavior to occur in your setup.

Being able to toggle any switch in the application requires feedback from the device hosting your Roon core, so something could possible be “hung up” core side. Besides the mentioned “switch”, are things behaving as expected? Furthermore, if you were to access Roon on another remote device, do you receive the same results when trying to engage the “sample rate conversion” feature?


Everything else is ok. Sounds great. Don’t know what you mean by access from another source? Say more.

@ted_betley ---- Apologies for any confusion, please allow me to clarify.

If you were to control Roon from another device acting as a remote, say another laptop, tablet, or perhaps a desktop computer. Are you still having this issue with the “sample Rate Conversion” switch not being able to be set to “enabled”?

Furthermore, when you are trying to interact with the switches in Roon are you tapping it (them) OR are you swiping?


Ok I’ll try to setup my ipad as a Remote. WRT setting switches I use my mouse.