Nexus 6P (Android 8) & P8 lite (Android 7) remote troubles

Looks like Roon Rock and Android are not compatible - I have the same issue using a Google Nexus 6p running android 8 and Huawei P8 lite running android 7. Only way I can connect is to restart the roon server then I can see the server for about 10 mins, then it disappears again. Looks like I will have to buy a dreadful apple ipdad. I think Roon should make it clear that the system is not stable with android devices.


When a commonly used feature, such as Android remote, has a bug then Support gets inundated with reports. We’re not seeing that. What we are seeing are sporadic reports from a few users which are difficult to reproduce. That is more consistent with an issue arising from the users configuration than a bug, although it is always possible that a bug only shows up under particular conditions.

I would encourage you to open a new thread, describe your network hardware and software with as much detail as possible, and set out the steps that lead to the problem.

1 Like

I’m using a Pixel XL (the first one, running android 8.1) with my ROCK NUC w/o issue. My network is a very simple Eero based ethernet/wifi situation.

What’s your network like?

Hi @JOHN_DAY ---- Thank you for the feedback, the insight is appreciated!

Like Danny, I am using a Nexus 6P as a Roon remote in very basic setup (NUC w/ROCK + Router) and have not experienced any of the issues you are experiencing. To help aide in our evaluation of this behavior you are reporting, may I very kindly ask you to please provide the following information:

  • A brief but accurate description of your current setup using this link as a guide.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the “tools” being utilized that make those connections possible.

  • Since noticing this behavior have you…

    • Tried rebooting any relevant networking hardware (router, switch(es), etc)?

    • Reinstalling the application on the mentioned remote devices?

  • Additionally, what is the experience like when the following tests are performed:

    TEST #1:

    1. Shut down your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Roon should be on the “Searching For Core” screen
    4. Start up the Core

    TEST #2:

    1. Start up your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Kill the Roon app
      (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
    4. Restart Roon on on your Remote


Hi Eric

Thank you for offering to look at the issue.

Roon Server Software
Roon Version 1.4 (build 306) stable

Operating System
Version 1.0 (build 157) stable

NUC7i7BNH NUC with 8 GB of RAM and a 128 GB M.2 SSD
Music stored on internal 2.5" 1TB HDD

Android App Verion V1.4 build 306

The NUC plugs directly into a BT Home Hub 5 using cat5 network cable.
The BT home hub uses the standard configuration that it came with, Ive not made any changes to it.

The problem I have is once the android devices go to sleep, they connot re-discover the core.
I have rebooted the NUC, the network and both Andoid phones.
I have reinstalled the roon remote app on the Nexus 6P and huawei P8.
Ive not reinstalled the Rock/Roon on the NUC.

Test #1 - following this test allowas me to re-discover the core.
Test #2 - still unable to re-discover the core.

I guess there must be some setting in the BT Hub 5 thats stopping the connection?

Thanks for your help


Thank you for the follow up @JOHN_DAY, I appreciate you taking the time to answer my questions and share the observations you made when performing the mentioned troubleshooting exercises in my previous :microscope::+1:

Continuing forward, I would like to see if we can trigger a change with your remotes by having you make the following adjustment:

  • Go into “settings” and select “Battery”.
  • In the right hand corner of the screen please select “battery optimization” from the “3 dot menu”.
  • You should see a header at the top of the window saying “not optimized” with a little drop down next to it. Click the dropdown and choose “All apps”.
  • Once the “All apps” window is open navigate to and select “Roon”.
  • Once Roon has been selected please choose “Don’t optimize”.
  • With this adjustment in place please verify what the experience is like with the Roon remote app.


**Note: I would recommend performing this on one remote at a time just in case the experience is different between the two.

As suggested I have made the changes to the battery settings. This has made an improvement as the Roon app remains running and connected to the core when the phone goes to sleep. When the phone goes to sleep the app appears to run in the background for about 20 mins then closes itself down, then when I open the phone and restart the app it wont find the core without me restarting the core.
I think we are making some progress and any further help would be appreciated.


Hi @JOHN_DAY ----- Thank you for giving the proposed test a shot and sharing the observations you have made. Very appreciated!

Let’s try to make one more adjustment to your remote devices. Please see below.

  • Go into “Settings” and select “Security & Location”

  • Next to “Screen lock” you will see a little “cog” symbol, click the “cog” to bring up the “Settings” window.

  • The first field you will see is “Automatically lock”, please change this to “Immediately”

Let me know how the remotes perform after the above adjustment!

Hi Eric

Still no luck Im afraid, I changed it to immediate, the problem still persists. I also tried 30 minutes but didnt make any difference.