No access to Roon playback from any device

Roon Server Machine

Version 1, build 259, running on Nucleus+

Networking Gear & Setup Details

All Unifi network, all ethernet connections, no vpn

Connected Audio Devices

PS Audio AirLens, ethernet connected to network, into Benchmark DAC and amp

Number of Tracks in Library

30,000

Description of Issue

Can access Nucleus on browser but can’t make connection to music server

Hi @Martin_Dooney,

Thank you for your post. The most common culprit for Remote connectivity issues on MacOS is the presence of private networks or multiple subnets within your local network.

In your Unifi network, verify that the Quality of Service (QoS) settings aren’t deprioritizing the IP address you’ve set up for your Nucleus+. I’d also verify that multicast and IGMP snooping are enabled.

You appear to be using a Mac as a Remote in your screenshot. Are there are VPNs, proxy servers, private WiFi addresses, or other third-party network security features on this machine? This Mac will need an IP address on the same subnet as that listed in the Nucleus+ web administration above. I’d verify that it’s not inadvertently connecting to a separate WiFi band, separate subnet, etc.

We’ll keep a lookout for your response. Thanks!

Thanks for getting back Connor.
Given your comments, I ran Windows virtual machine on my Mac and installed Roon app there. The phone now sees that as a different Roon server and then connects and directs streams properly. Howerver, the playlists, for example, are not complete and I didn’t look to update from a backup since I’d rather solve the original problem which, as you suggest, is mac running up against changes in the unifi network settings. The mac based backup might not work with the windows version anyway? Good to know that there’s nothing amiss with the Nucleus. Suggestions as to what might need attention on the network side welcome.

I would suggest operating your Roon setup all on one subnet. This includes the Nucleus+, endpoints and remote devices.

No vlans, disable any QoS.

Use Ethernet where ever possible, if not temporarily try Ethernet.

Hope some of this helps

This might not be the most elegant solution but I deleted and re-installed the Roon app on my mac and connected to the Nucleus+ from there. (and lost the Windows Roon server, as expected since I only have the single licence) That’s worked fine and I can now stream as before from all my mac devices. I didn’t make any changes to the network.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.