No access to Roon server with iPad as remote device

No access to Roon server with iPad as remote device

Roon Core Machine

    1. Small fanless Computer based on Intel ATOM E3950, 8GB RAM (LTSC 2019, Win 10 pro, Ubuntu 21.10)
    1. Mac Mini M1, 2021, 16GB RAM (mac OS Monterey, 12.1)

Roon Sever 1.8 (build 882 stable)

Connected Audio Device
Devialet 400 connected over Ethernet

Remote’s
iPhone XR
iPhone 12 pro
ipad pro 2016
main remote => iPad pro 11Inch (MTXQ2TY/A), 2018 (iPad OS 16.2)

Number of Tracks in Library
More than 150,000 tracks

Description of Issue
Since Roon Update 882 I was not able to connect to the Roon Server anymore with my iPad pro 2019. Interesting: All other listed remote devices work.

My troubleshooting efforts so far
All reboots (router, iPad, server) brought no results. Deleting the app and reinstalling it has brought no results.

After I only have problems with access with my iPad Pro 2019, I still looked for the issue with my server first. I then disabled all firewalls on the operating system (Windows IoT, LTSC2019) without success. I then installed a Windows 10 pro, thinking it was the Windows. Everything until then without success, same problem as before.

After that I tested my Mac mini M1 as a server. With it I had no more problems with the access via iPad, however I had permanently Kernel Panics and thereby total crashes, any tips, like avoid energy saving mode etc. did not help, I even disconnected the screen completely. After a certain time - pang, the crash followed.

Than again back to the small fanless PC. I have this time completely formatted the hard drive and installed Ubuntu 21.10. With the guidance of Root, I was able to successfully install Root on Ubuntu 21.10. It runs very smoothly, unfortunately the error still remains.

I still removed all Network switches and connected the root server directly to the WiFi router, also without success.

I then reset the iPad and behold the Root Remote app was able to connect to the server! However, this did not last long, after about 2-3h again the error message “Looking for your Room Core”. I repeated this process 2x with the same result.

Does anyone have any idea what else I can do? What am I doing wrong?

Probably the iOS 16.2 is not an official iOS version.

Hi @Florian_Egger,

Here’s my read on the situation–

Your mini fanless PC is very far from meeting our recommended specs. It is an Intel Atom from 2016 and you have a sizable library at 150,000 tracks. I’m guessing that it is just not able to handle the workload presented by such a large library. Personally, I wouldn’t invest time into trying to make such a limited computer host a library of this size.

The M1 Mac certainly has the performance to run this library, and that’s probably your best way forward. The fact that you are seeing kernel panics and whole system crashes suggests that you are having a problem at the operating system or hardware level, however.

Modern operating systems are designed so that it’s impossible for an application, no matter how poorly behaved, to cause a kernel panic. That always indicates a bug in the operating system, a driver, or a hardware failure. Roon does not include any drivers, it is just a normal application. There might be something wrong with your Mac. Certainly, if you are not running the latest macOS, I would start there, but you may need to pursue this with Apple. We have several people on the team, including myself, using M1-based Macs and iPads. Roon has been stable and performant on these machines, so once the OS/hardware-level issue is resolved, I would expect this to work fine from Roon’s perspective.

Hi Brian
Thank you for your reply.

I am aware of the limitations of the Mini PC. I would like to use the Mac Mini, however I have not been able to get the kernel panics to go away. I have to say that the Mac is massively stable. I have never had any crashes. Only the Roon app crashes because of said kernel panic. Of course I’m running the latest IOS version.

In the meantime, however, I have the following update.:
I tried to ping my Roon server (Mini PC) with the iPad (ping - network utility) and look, the ping is not getting through. In parallel i’am able to ping to the Diskstation. I have therefore reset the WiFi password encryption from WPA2 to WPA on my router. And I can access my Roon server with my iPad now again. I will now investigate the issue further with the manufacturer of the router (UPC Giga Connect Box) and apologize for the circumstances I have caused the Roon support.

Thank you so much for your efforts.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.