No album art on newly added albums

A few days ago, Roon stopped including album art when I add a new album from Tidal to my library. The edit/identify_album feature will retrieve the album “manually” though. The only system change I recall making (prior to this problem) was to reassign main storage from a Mac Mini to the hard drive of my sonicTransporter i9. I haven’t tried changing it back yet.

Hello @Tom_K, have you signed out and back into TIDAL since this started occurring?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

No, I had not signed out and back into Tidal. I just tried that, and when I add a new album the same problem occurs. Plus I get a message saying it is taking longer than usual.

The issue occurs every time I try to add a new album.

My Core machine is a sonicTransporter i9.
Latest Roon build, I think. 1.7 build 667.
Cable to Orbi modem/router then to Orbi satellite router next to hifi system; sat router feeds sTi9 by wired ethernet.

Music Library is on a SS drive in the sTi9;
9,816 tracks according to Roon display;
I use Tidal.

Hello @Tom_K, have you tried going into Settiings>Setup and clearing your image cache? Please also try temporarily disabling your firewall/antivirus and seeing if that helps?

Clearing the image cache did not help.
The firewall was off for recent downloads; no antivirus active either.

I’m seeing the following message when music is playing and I click on the spinning progress circle in the upper right corner:

However, I seem to have the latest Roon version already.

Hello @Tom_K, for the metadata improver message, the message should go away if you reboot. Please let me know if that works!

The album art seems to be working again.
When I added an album just now, I did not notice that message but I did get the art. It happened fast enough that I didn’t get much of a chance to click on that spinning progress circle.

I had restarted the Roon server in the past 2 days or so.

Hello @Tom_K, glad things are working again! Please let us know if you have any further issues.