No album information on car display using ARC w/ bluetooth connection

Roon Core Machine

Hello.
I am running ROCK on NUC latest build

Networking Gear & Setup Details

Fully ethernet connected between all systems and ISP router/modem.

Connected Audio Devices

Connection is from my Galaxy S21 via Bluetooth to car audio

Description of Issue

Using ARC in my Audi connected via Bluetooth I have no album information on the car display and only half the time is the song duration counter functional. My car is a 2013 so a number of years old, but I don’t have this issue using the Qobuz app, and never had the issue using Spotify. The car is too old to offer Android Auto.

All playlists consist of songs/albums created from Qobuz content. I don’t have any music local to my phone.

ARC displays all song/album information and appears to be fully functional aside from not providing album and song duration information to my car’s display.

Honesty, I cannot say when this started, but it has been a problem for many months.

Thanks for any help.

I’ve seen a similar issue over the past few months. And my setup is newer (S22 + Android Auto). Spotify works perfectly, Qobuz app is not perfect but good.

I did reset ARC, which helped for a while but not a permanent fix.

Hmmm… I don’t believe I have tried resetting ARC since this started happening. I will give that a go.
Thanks for the suggestion.

It might be, that this is not a Roon problem, as the same happens while using Apple Music native app.

Exactly the same phone in another car works perfectly.

There might be a compatibility issue when it comes to picture format or even file sizes. Why I’m saying that: I observed more problems with large album pictures, I’ve added myself to albums…

Just my 2 cents

Regards
Stefan

Stefan -
In this case the information shown on my car’s screen is all text. My car isn’t new enough to show album art. It may be a compatibility issue, though it is strange the other two apps I mentioned are able to provide the album name during playback. And, now that you mention it, I trialed Apple Music for a short time before moving to Qobuz and that worked as well.

I have confirmed resetting ARC didn’t fix the issue.

I did notice, looking at the “now playing” screen, for lack of a better way to put it, there is the name of the song and the name of the band but other than a picture of the album there is no actual text showing the name of the album. Maybe this is the issue?

Hey @Gideon_Kane,

Ben with the support team here, thanks for writing in! Our team was able to review your issue, and have a few follow-up questions:

  • If you try to play a larger file around the time you experience this issue, does playback fail?
  • What else can you do in Arc once it gets into this state? Is behavior normal outside of the lack of album information?

Sharing a screenshot of this would be helpful as well, if possible :pray:

Thanks, Gideon!

Benjamin -
Hello.
Though I experience some other issues time to time when using ARC, this isn’t about functional problems with ARC. It is just an issue with the missing album title on my car’s display.

I should be able to grab an image and posted it up tomorrow.

Thanks

Attached is an image of what I am seeing when using ARC.

Hey @Gideon_Kane,

Thanks for the update.

When you stream music from other apps, are you able to see the album art?

To be clear, my car doesn’t have the option to show album art. As you can tell in the attached picture there is a text-based area for the album title.

And yes. As previously mentioned, Apple, Spotify, Qobuz all populate the album title.

Thanks

Hey @Gideon_Kane,

I was able to take your issue to our Arc team today, and we saw a trace in your core diagnostic that may be worth investigating:

[Firmware Bug]: Your BIOS is broken; bad RMRR [0x000000007b800000-0x000000007fffffff]

As a next step, let’s look at reconfiguring/installing the BIOS on your ROCK. Here is more information on this:

Let me know if this helps, and if you have any additional questions!

Thanks for the information. I followed those instructions when I built the NUC.
I am running the latest firmware available which is from 2020 (0073).

I will confirm the recommended settings, but a quick search suggests that is a pretty common error.

Thanks

Just to follow up with your suggestion, I found nothing out of the ordinary with any NUC setting.

Paying more attention to this now, I am noticing this is more random than previously thought. I notice that almost without fail album information does not work on my way to work in the morning. If I run out at lunchtime, often but not always album information will be visible for a handful of songs before it stops working.

The other night I drove home late at night for the first time in a while and album information was available the entire time. That is the first time in months I can remember it working for any length of time.

I realize this is all anecdotal and time of day seems like an odd variable to figure into this issue, but I am just trying to convey my observations.

Cell signal strength a viable culprit?

Hey @Gideon_Kane,

Thanks for the update! If possible, can you please share a screenshot of your Roon Arc settings> internal storage?

Our team is needing to investigate things a bit deeper, but we are seeing a large amount of memory pressure issues on your mobile device, which typically refers to a lack of space on the device.

I should be following up with more information early next week. Thanks! :+1:

Here you go.

Hi @Gideon_Kane,

Thanks for the update. Our team has continued to dig into this issue further, but haven’t had much luck.

We’re aware of known issues linked between Android / Bluetooth and how the combination responds to metadata. Pairing this with the year of your vehicle, we’re unable to test in a similar environment thoroughly.

I’ll certainly keep you updated with any progress made, and I apologize for not having any immediate next steps.

Thanks for getting back to me on this. Appreciate the effort.

Mind boggling this is only an issue with Roon ARC. Tidal, Qobuz, Apple, Spotify… and most recently PlexAmp have zero issue with this. AND Roon ARC works sometimes which drives me insane.

As an alternative solution, you could also look into installing an Android Auto adapter (i.e. one from Wakaa, but there are others, although they all seem to come from the same factory anyway). That gives you full and proper Android Auto (CarPlay as well) support, and ARC works quite well with it.

Boris -
I was just looking into that exact option.
It is something I have been interested in for a while, and with this issue there is now extra motivation.

Thanks