"No albums found in your library" after upgrade to 1.3


After upgrading to 1.3 (build 196), I receive the above error in the remote App. It says “it looks like one of your storage locations could be offline” - which is incorrect.

I am running a Sonic Transporter i5 with version 2.3 software on it.
I am running Roon Core 1.3 (build 196) on it.
My Roon DB is 1.2G in size.
I’m running the latest Roon remote app on my Samsung android tablet.
I use a Synology NAS (DS1812+) for music storage.
I’ve rebooted my Synology NAS twice.
I’ve killed the active CIFS “music” connection on my NAS twice.
I’ve rebooted Roon Core twice.
I’ve rebooted my sonictransport i5 twice.
I’ve rebooted the remote app about 15 times.
When I check storage settings in Roon remote it says it is connected to my network share \diskstation\music and is watching for files in real time.
When I go to choose folder and navigate to the network share it says the folder is empty - which is incorrect!
When I tell it to force rescan it does so for about half a second and then continues to give me the same messages mentioned above about no albums etc.
I have cleared the cache in the remote app and restarted - same result.
I have deleted the network share and recreated it - same result.

I have about 1000 albums in my library and they were previously playable through v1.2 of Roon.
I can navigate to my music folder on my NAS through my Windows 7 PC. I can also playback music from my NAS through my PC.
I can navigate to my music folder on my NAS through my Oppo BDP-105 and playback music without issue also.

Clearly something is wrong with Roon!
I looked through the support topics and no-one seems to have encountered the exact same combination of issues as I have thus far.
Please help!

Problem resolved!

I decided to add a USB HDD to the sonic transport to see if I could get Roon to work with non-network based media playback.

I navigated to the add folder option in the storage settings of the roon remote and proceeded to select the sonic transport (instead of the diskstation) and then the hard disk icon. I then selected the storage sub-folder. I found a directory called music (it also contained a video and photos folder) and when I selected it, all of the music files contained in the music directory on my Synology NAS were visible. I added the folder to Roon and all of my music was re-imported successfully.

I added 2 new albums to my NAS shortly after and they were also imported to Roon successfully once I completed a force rescan.

Roon is still reporting the same issues with the folder on my NAS in the storage settings so there’s definitely something wrong with the way network shares now work; but I’m happy I have my music back, Roon working again and I don’t care that it thinks it is using local storage instead of network storage.