No Artwork or Frozen Artwork with ARC/CarPlay

Roon Core Machine

Roon Core = ROCK Roon Version 2.0 (build 1211)
Intel NUC = NUC8I5BEK3 i5 8259U
Operating System Version 1.0 (build 254) production

Connected Audio Devices

iPhone7 15.7.3
Audi A3 (2022 model)

Number of Tracks in Library


Description of Issue

This problem relates to Arc and CarPlay. Whilst the audio works well the artwork doesn’t work for me. I’m using Arc in offline mode only in the car with a small playlist of downloaded tracks from my local collection.

The playlist appears ok in CarPlay but there’s no artwork displayed with the playlist tracks. The main issue is that quite often there is no artwork for the tracks I play or it will either freeze on the artwork for the first track played or change artwork correctly for 5 tracks only (it always seems to be 5) then displays the same artwork for all tracks.

Other apps such Qobuz, Spotify all seem to work well with regards to artwork.

This problem can be reproduced. I also tried uninstalling ARC and setting up again, same problem.

I have exactly the same issue. Artwork seems to display correctly when using the app directly on the phone, but when using via Carplay more often than not the artwork is either not there or sometimes in ‘now playing’ stuck the artwork for a previous item. I’ve tried resetting the ARC app on my phone numerous times which seems to temporarily fixed the issue as long as you start using ARC Carplay when you have a very good phone signal. If (or as soon as) you have a weaker signal the album art won’t load, despite the signal still being good enough for playback and for album art of work on other music streaming apps via Carplay, or on ARC if used directly on the phone. It isn’t restored on its own when the signal improves, it takes a reboot of the app.

I do have a Bluetooth adaptor in my car and I tried it wired in case that was the issue, but the behaviour seems the same both ways.

Hope a solution can be found.

Exact same issue here. Except that regardless of signal, I can’t get any artwork to return to CarPlay until I perform a Reset. The Reset procedure is pretty terrible - no feedback in the UI, requires a force-restart 2 or 3 times to get past the reset screens. Very disappointed with the overall quality of ARC.

Apparently it’s a known issue but very frustrating…

No update on likely timescales for a fix though :anguished:

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.